This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 249277 - It seams that NB sometimes does not use the last version of the code, however the oldest one
Summary: It seams that NB sometimes does not use the last version of the code, however...
Status: NEW
Alias: None
Product: java
Classification: Unclassified
Component: Project (show other bugs)
Version: 8.0.2
Hardware: PC Windows 7
: P3 normal (vote)
Assignee: Tomas Zezula
Depends on:
Reported: 2014-12-10 21:55 UTC by rudyment
Modified: 2015-01-09 10:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:

IDE log (53.25 KB, text/plain)
2014-12-10 21:55 UTC, rudyment
Screenshot of the NB showing wrong breakpoint (122.18 KB, image/png)
2014-12-10 22:08 UTC, rudyment

Note You need to log in before you can comment on or make changes to this bug.
Description rudyment 2014-12-10 21:55:02 UTC
Product Version = NetBeans IDE 8.0.2 (Build 201411181905)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.8.0_25
Runtime = Java HotSpot(TM) 64-Bit Server VM 25.25-b02

Sometimes the program starts to behave as several days before.
All modification are forgotten.
When I want to step the program to discover the reason, I see, that program behaves differently as source code tells.
The brakpoints are not able to be set at regular places, new variables do not exist and so on (see attached picture).
Clean and build of such program does not help.
Restarting NB does not help.
When I copy all the source codes into another dictionary and run it under other IDE, e.g. BlueJ, everything works as expected.
When I run the copied source codes in new NB project, everything works fine.
Only the original project works bad -- it sends to compiler some older versions of certain classes.
I do not use any external library, only the standard one.

The worst news is that this is not only singular behavior. It happen relatively often.
For a long time I was not able to discover, what the reason is.
Today the behavior was so pregnant, that it was clear, that it runs certain older version of several classes (not all, only several of them).
I am afraid, that I cause this behavior by often copying of the source files.
When I write my textbook, I solve one project throuhg the all textbook.
Each chapter uses the source dodes, which are very similar to the codes from the previous chapter.
Therefore at beginning of the new chapter I copy the old sources into ne package and show there, how they can be made better.
From time to time I modify certain common classes and these classes then sometimes show the above described strange behavior.
Comment 1 rudyment 2014-12-10 21:55:07 UTC
Created attachment 151027 [details]
IDE log
Comment 2 rudyment 2014-12-10 22:08:37 UTC
Created attachment 151029 [details]
Screenshot of the NB showing wrong breakpoint

Here the NB complain, that the set breakpoint is at the wrong line. However it was wrong is some previous version. Now, in time when the breakpoint was set, the line was fine.

The Editor accepted it, because I set the breakpoint at the statement.
However when running, the debugger complains.

When I run this code in another IDE, or in NB in new project with another source folder, where I have copied the source files using some external file manager, no such problem occurs