This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 251130 - IDE can't find generated model from Eclipselink
Summary: IDE can't find generated model from Eclipselink
Status: RESOLVED DUPLICATE of bug 218658
Alias: None
Product: javaee
Classification: Unclassified
Component: Code (show other bugs)
Version: 8.0.2
Hardware: PC Windows 7 x64
: P2 normal (vote)
Assignee: Petr Hejl
Depends on:
Reported: 2015-03-12 13:19 UTC by FiruzzZ
Modified: 2015-04-16 07:46 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:

IDE log (136.29 KB, text/plain)
2015-03-12 13:19 UTC, FiruzzZ

Note You need to log in before you can comment on or make changes to this bug.
Description FiruzzZ 2015-03-12 13:19:29 UTC
After make some changes in the model, the IDE can't find one than another GeneratedModel_.
I tried to make minimal changes in the class/ model, some aggressive refactors (renaming the class) and even removed the @Entity annotation to see if the IDE refresh its cache but nothing worked
Also tried upgrading Eclipselink libs to the last release..
The cache of the IDE must be erased to this situation get solved.

PD: this bug has existed since I can remember (netbeans 6 at least)

Product Version = NetBeans IDE 8.0.2 (Build 201411181905)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.8.0_11
Runtime = Java HotSpot(TM) 64-Bit Server VM 25.11-b03
Comment 1 FiruzzZ 2015-03-12 13:19:34 UTC
Created attachment 152579 [details]
IDE log
Comment 2 Petr Hejl 2015-03-19 08:08:28 UTC
Please can you provide clear steps to reproduce? It is not really clear from the description. Not sure what is meant by "IDE can't find" and how the model was created. Thanks in advance.
Comment 3 FiruzzZ 2015-04-13 16:23:49 UTC
I found some not too old duplicated reports of the same bug, better described. But we all eventually came up with the same odd solution: remove the cache
Comment 4 FiruzzZ 2015-04-13 16:24:22 UTC
Bug 218658
Comment 5 Petr Hejl 2015-04-14 14:47:17 UTC
Ok, so is this duplicate of issue #218658?
Comment 6 Petr Hejl 2015-04-16 07:46:42 UTC

*** This bug has been marked as a duplicate of bug 218658 ***