This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 252360 - Fail to clone a git repository from DCS with multibyte chars in URL
Summary: Fail to clone a git repository from DCS with multibyte chars in URL
Status: NEW
Alias: None
Product: versioncontrol
Classification: Unclassified
Component: Git (show other bugs)
Version: 8.1
Hardware: PC Windows 7
: P4 normal (vote)
Assignee: Ondrej Vrabec
Depends on:
Reported: 2015-05-12 12:36 UTC by Tomas Pavek
Modified: 2015-07-10 12:01 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Pavek 2015-05-12 12:36:30 UTC
Login to Callahan Hub as french.tester, go to project test-French. There are several repositories, one of them named ようこそ.git.

Trying to clone this repository in NetBeans fails, either going through the team server support (for getting sources) or Git clone wizard and pasting the URL.

The exception is:

org.eclipse.jgit.errors.NoRemoteRepositoryException: not found
	at org.eclipse.jgit.transport.TransportHttp.connect(
	at org.eclipse.jgit.transport.TransportHttp.openFetch(
	at org.netbeans.libs.git.jgit.commands.ListRemoteObjectsCommand.runTransportCommand(
Caused: org.netbeans.libs.git.GitException: not found
	at org.netbeans.libs.git.jgit.commands.TransportCommand.handleException(
	at org.netbeans.libs.git.jgit.commands.ListRemoteObjectsCommand.runTransportCommand(
	at org.netbeans.libs.git.jgit.commands.GitCommand$
	at org.netbeans.libs.git.jgit.commands.GitCommand$
	at Method)
	at org.netbeans.libs.git.jgit.commands.GitCommand.execute(
	at org.netbeans.libs.git.GitClient.listRemoteBranches(
	at org.netbeans.modules.git.client.GitClient$
	at org.netbeans.modules.git.client.GitClient$
	at org.openide.util.NetworkSettings.suppressAuthenticationDialog(
	at org.netbeans.modules.git.client.GitClient$CommandInvoker$1$
	at org.netbeans.modules.git.client.GitClient$CommandInvoker$
	at org.netbeans.modules.git.client.GitClient$CommandInvoker.runMethodIntern(
	at org.netbeans.modules.git.client.GitClient$CommandInvoker.runMethod(
	at org.netbeans.modules.git.client.GitClient$CommandInvoker.runMethod(
	at org.netbeans.modules.git.client.GitClient$CommandInvoker.access$400(
	at org.netbeans.modules.git.client.GitClient.listRemoteBranches(
[catch] at org.netbeans.modules.git.ui.clone.RepositoryStep$RepositoryStepProgressSupport.perform(
	at org.netbeans.modules.git.client.GitProgressSupport.performIntern(
	at org.openide.util.RequestProcessor$
	at org.netbeans.modules.openide.util.GlobalLookup.execute(
	at org.openide.util.lookup.Lookups.executeWith(
	at org.openide.util.RequestProcessor$
Comment 1 Tomas Pavek 2015-05-12 12:44:46 UTC
This was reported on JDev, I can reproduce it in NetBeans as well. But only on Windows, I was able to get the repository cloned on Linux.

I've debugged it to org.netbeans.libs.git.GitClient.listRemoteBranches() where the repository URL set to the executed commend was still good.

Cloning the default test-french.git worked fine. BTW trying a non-existing repository name led to RemoteRepositoryException instead of the NoRemoteRepositoryException which happened when using the multibyte chars - and also when I tried to replace them with ???? (I guess that's what happens somewhere along the way).
Comment 2 Tomas Pavek 2015-05-12 12:50:55 UTC
Also the info/refs URL listed in the exception itself is good (the ???? appear only when printed to log) - I can get the refs file if pasting the URL to browser.
Comment 3 Ondrej Vrabec 2015-05-12 12:53:35 UTC
Kidding, right? Who names their repositories with non-ASCII chars?
Can you clone in commandline? How can i log in? I don't know the password.