This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 252742 - Wildfly plugin doesn't work with Wildfly 9 Servlet only distribution
Summary: Wildfly plugin doesn't work with Wildfly 9 Servlet only distribution
Status: RESOLVED FIXED
Alias: None
Product: serverplugins
Classification: Unclassified
Component: WildFly (show other bugs)
Version: 8.1
Hardware: PC Windows 7
: P2 normal with 2 votes (vote)
Assignee: ehsavoie
URL:
Keywords:
: 252728 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-02 10:24 UTC by jherkel
Modified: 2015-08-06 14:46 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jherkel 2015-06-02 10:24:13 UTC
I have tried Wildfly 9.0 Servlet Only Distribution and there is a problem in communication between wildfly and plugin. I was able to start the Wildfly but I couldn't stop it. Also there aren't any subnodes under the Wildfly server in "Services/Servers" view. As the next step I have tried to kill server but after clicking on the menu, Netbeans stopped to response and after some time I could see only a black window. With full distribution everything was working correctly.
Comment 1 ehsavoie 2015-06-03 12:04:25 UTC
Which version of netbeans are you using ?
This may work with the nightly build thought
Comment 2 jherkel 2015-06-03 12:26:08 UTC
Product Version: NetBeans IDE Dev (Build 201506020001)
Java: 1.8.0_45; Java HotSpot(TM) 64-Bit Server VM 25.45-b02
Runtime: Java(TM) SE Runtime Environment 1.8.0_45-b14
System: Windows 7 version 6.1 running on amd64; Cp1250; en_US (nb).
Comment 3 ehsavoie 2015-06-05 11:47:06 UTC
It seems the authentication behaviour of the Servlet Lite distribution is different from the full.
I need to check where the issue is on their configuration
Comment 4 ehsavoie 2015-06-17 07:35:38 UTC
*** Bug 252728 has been marked as a duplicate of this bug. ***
Comment 5 flynnk 2015-07-31 21:10:05 UTC
This still not does not work with the NetBeans nightlies.

Product Version: NetBeans IDE Dev (Build 201507310002)
Java: 1.8.0_51; Java HotSpot(TM) 64-Bit Server VM 25.51-b03
Runtime: Java(TM) SE Runtime Environment 1.8.0_51-b16
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
User directory: C:\Users\kflynn\AppData\Roaming\NetBeans\dev
Cache directory: C:\Users\kflynn\AppData\Local\NetBeans\Cache\dev

It would really be terrific if this fix could be backported to 8.0.2, as 8.1 is not scheduled for release until October.  This is a major issue for users of Wildfly.
Comment 6 ehsavoie 2015-08-06 14:46:06 UTC
Working on backporting it.