This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 255715 - All JavaFX samples default to JDK 7 and WILL NOT RUN when IDE is on JDK 8
Summary: All JavaFX samples default to JDK 7 and WILL NOT RUN when IDE is on JDK 8
Status: VERIFIED INVALID
Alias: None
Product: javafx
Classification: Unclassified
Component: Project (show other bugs)
Version: 8.1
Hardware: PC All
: P3 normal (vote)
Assignee: Antonin Nebuzelsky
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-06 07:17 UTC by Lou Dasaro
Modified: 2015-10-13 18:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
Output from RUNning sample program (Xylophone) (3.19 KB, text/plain)
2015-10-06 07:17 UTC, Lou Dasaro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lou Dasaro 2015-10-06 07:17:24 UTC
Created attachment 156539 [details]
Output from RUNning sample program (Xylophone)

Currently in NB 8.1(RC), all JavaFX Sample programs default to JDK 7, and will NOT run when built on NB IDE running on a JDK 8 platform. Run listing attached.
This will be very confusing for new users.

Since JDK 7 is deprecated, I would suggest the sample programs should all be updated to default to JDK 8. 

Test environment:
Product Version: NetBeans IDE 8.1 RC (Build 201510012201)
Java: 1.8.0_66-ea; Java HotSpot(TM) Client VM 25.66-b02
Runtime: Java(TM) SE Runtime Environment 1.8.0_66-ea-b02
System: Windows 8.1 version 6.3 running on x86; Cp1252; en_US (nb)
Comment 1 Antonin Nebuzelsky 2015-10-13 12:43:44 UTC
Not reproducible with 8.1 RC on OSX.

* started IDE on 7u51
* created sample project Xylophone, runs without problems
* restarted IDE on 8u60
* the same project runs without problems

In both runs of the sample project the JDK version NB is running on top of is used for the sample's execution. No specific JDK version is hardcoded in the project's settings.

Am I missing something in your steps to reproduce?
Comment 2 Lou Dasaro 2015-10-13 18:50:00 UTC
I can't replicate it anymore; previously occurred on both Win 8.1 and Ubuntu 14.04 using NB 8.1 RC.
I suspect I may have been testing bug 255710 on both platforms and forgot to change the IDE's run platform back to JDK 8. Otherwise IDK.

Verifying as invalid. If this anomaly reoccurs, please reopen with my apologies.