This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 256166 - ClassNotFoundException: org.jcodings.Encoding
Summary: ClassNotFoundException: org.jcodings.Encoding
Status: NEW
Alias: None
Product: web
Classification: Unclassified
Component: YAML (show other bugs)
Version: 8.1
Hardware: All All
: P3 normal with 1 vote (vote)
Assignee: Petr Pisl
: 262793 (view as bug list)
Depends on:
Reported: 2015-10-25 10:45 UTC by Ruthless
Modified: 2016-07-13 09:38 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 220757

stacktrace (4.93 KB, text/plain)
2015-10-25 10:46 UTC, Ruthless
Contents of jcodings.jar (24.52 KB, text/plain)
2016-05-04 19:04 UTC, jasny
stacktrace (v8.1) (17.32 KB, text/plain)
2016-05-04 19:08 UTC, jasny

Note You need to log in before you can comment on or make changes to this bug.
Description Ruthless 2015-10-25 10:45:59 UTC
This issue was reported manually by Ruthless.
It already has 1 duplicates 

Build: NetBeans IDE 8.0.2 (Build 20150619-debian-8.0.2)
VM: OpenJDK 64-Bit Server VM, 24.85-b03, OpenJDK Runtime Environment, 1.7.0_85-b01
OS: Linux

User Comments:
Ruthless: Program was frozen and suddenly asked me if I want to report a problem.

java.lang.ClassNotFoundException: org.jcodings.Encoding
   at java.lang.ClassLoader.loadClass(
   at sun.misc.Launcher$AppClassLoader.loadClass(
Comment 1 Ruthless 2015-10-25 10:46:01 UTC
Created attachment 156967 [details]
Comment 2 jasny 2016-05-04 19:04:09 UTC
Created attachment 159539 [details]
Contents of jcodings.jar
Comment 3 jasny 2016-05-04 19:08:39 UTC
Created attachment 159540 [details]
stacktrace (v8.1)
Comment 4 jasny 2016-05-04 19:18:05 UTC
Explicitly prepending `jcodings.jar` to the classpath by running `netbeans --cp:p /usr/share/java/jcodings.jar` solved the problem./

Workaround for others with this issue:

- Edit `netbeans.conf` (on Ubuntu 16.04 `/etc/netbeans.conf`)
- Add the `--cp:p /usr/share/java/jcodings.jar` to `netbeans_default_options`
Comment 5 tetrode 2016-07-13 09:35:58 UTC
Solved my issue too, thanks
Comment 6 tetrode 2016-07-13 09:38:09 UTC
*** Bug 262793 has been marked as a duplicate of this bug. ***