This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 259128 - the run file option is grayed out when I right click on any hmtl file.
Summary: the run file option is grayed out when I right click on any hmtl file.
Status: RESOLVED DUPLICATE of bug 256585
Alias: None
Product: web
Classification: Unclassified
Component: HTML Project (show other bugs)
Version: 8.1
Hardware: All All
: P3 normal (vote)
Assignee: Tomas Mysik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-04 18:57 UTC by xucaen
Modified: 2016-05-24 13:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
IDE log (39.01 KB, text/plain)
2016-05-04 18:57 UTC, xucaen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xucaen 2016-05-04 18:57:04 UTC
Product Version = NetBeans IDE 8.1 (Build 201510222201)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.8.0_60
Runtime = Java HotSpot(TM) 64-Bit Server VM 25.60-b23

Reproducibility: Happens every time

STEPS:
  * I select my index.html file
  * Right click
  * select the Run File option

ACTUAL:
  nothing happens; run file options is grayed out/disabled.  Toolbar is also grayed out.

EXPECTED:
  I expected to be able to run my index.html file in a browser. It's been working fine all week, today I open up netb eans and I am not able to "run" any html files.
Comment 1 xucaen 2016-05-04 18:57:10 UTC
Created attachment 159538 [details]
IDE log
Comment 2 xucaen 2016-05-05 22:15:59 UTC
I made a video which shows how to recreate the video. Apparently, having a bower.json file present in the project folder causes netbeans to disable all of its web dev icons and the run file feature. You can see the video here: https://youtu.be/VpoMHynhibY
Comment 3 Tomas Mysik 2016-05-19 08:00:11 UTC
Seems to me that this issue will be fixed once issue #256585 is fixed. You can easily verify it by renaming package/bower.json to e.g. package2/bower2.json and restart the IDE.

Thanks for reporting.
Comment 4 Tomas Zezula 2016-05-24 13:39:32 UTC
Duplicate of #256585.

*** This bug has been marked as a duplicate of bug 256585 ***