This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 26356 - FileSet implementation needs an order preserving implementation
Summary: FileSet implementation needs an order preserving implementation
Status: RESOLVED FIXED
Alias: None
Product: projects
Classification: Unclassified
Component: Generic Infrastructure (show other bugs)
Version: 3.x
Hardware: All Solaris
: P1 blocker (vote)
Assignee: Jan Pokorsky
URL:
Keywords:
: 26603 (view as bug list)
Depends on:
Blocks: 23291
  Show dependency tree
 
Reported: 2002-08-07 18:47 UTC by Chris Webster
Modified: 2003-12-11 14:14 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Webster 2002-08-07 18:47:33 UTC
The time stamp checking support provided by Use
depenencies requires a FileSet implementation
which preserves order. This is needed to optimize
performance as the timestamp algorithm must save a
timestamp for each DataObject and requiring a
FileSet for each timestamp is to heavyweight.
Comment 1 Jan Pokorsky 2002-08-08 12:51:16 UTC
Why not. It seems reasonable to me. Will you require also any support in API related to the order?
Comment 2 Chris Webster 2002-08-10 01:40:06 UTC
The FileSet api seems sufficient. The iterator method would need to
ensure that the iteration order is the order in which the add method
was invoked. Other than this semantic requirement the api is
sufficient.
Comment 3 Jan Pokorsky 2002-08-19 13:27:08 UTC
*** Issue 26603 has been marked as a duplicate of this issue. ***
Comment 4 Jan Pokorsky 2002-09-17 10:29:17 UTC
Done. New module projects/filesets fulfils this requirement.