This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 26530 - Create a mechanism, that will interpret cvs errors
Summary: Create a mechanism, that will interpret cvs errors
Alias: None
Product: versioncontrol
Classification: Unclassified
Component: CVS (show other bugs)
Version: 3.x
Hardware: PC OS/2
: P3 blocker (vote)
Assignee: Ondrej Vrabec
Depends on:
Reported: 2002-08-15 06:39 UTC by _ gtzabari
Modified: 2011-11-24 09:44 UTC (History)
0 users

See Also:
Exception Reporter:

1st log (1.79 KB, text/plain)
2002-08-26 04:00 UTC, _ gtzabari
2nd log (1.15 KB, text/plain)
2002-08-26 04:01 UTC, _ gtzabari

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2002-08-15 06:39:55 UTC
dev build 200208090100
IBM JDK 1.3.1

   I can checkout a repository with no module name
(using "."), but if I use MODULE LIST, select one
and try to check it out I get:

String index out of range: <negative integer here>

   in the CVS output box. I would like to enable
CVS debugging output somehow to see what's
actually causing this failure. Anyone remember how
this is actually accomplished? :)

Comment 1 Milos Kleint 2002-08-26 03:22:10 UTC
can you attach the exception?
any steps to reproduce? what are your filesystem settings?
to get the trace of the protocol, add -J-DcvsClientLog=<filename> to
the runide.exe(.sh) startup.
Comment 2 _ gtzabari 2002-08-26 03:59:50 UTC
Hey Milos,

   When the error dialog pops up there is no way to see the entire
stacktrace (there is no "details" button, only "see log").

   I'm attaching the stdin/stdout log to this issue. Please let me
know if this is enough to fix it or if you need more input from me.

Comment 3 _ gtzabari 2002-08-26 04:00:44 UTC
Created attachment 7211 [details]
1st log
Comment 4 _ gtzabari 2002-08-26 04:01:00 UTC
Created attachment 7212 [details]
2nd log
Comment 5 Milos Kleint 2002-08-26 05:04:55 UTC
seems like the exception is eaten/catched somewhere :(
It could be an error in the UI code listening to the command, but, I'm
not sure. 
Comment 6 dmladek 2002-08-26 08:53:19 UTC
hmmm.... that's "interesting".
I'va got something similar/same when I exercised with NB34 RC2.
I've performed very quick=SANITARY test of javacvs module...
I was so supprised, when it happend...and it was happening me
repeatedly:-((( But latter after I some steps(which I will described
latter) I wasn't able to reproduce it:-/

-I took RC2 build installer and my option was to import older 3.4 

-I run ide, and didn't met any problem... Everyrhing was functional,
no error anywhere:-).

-javacvs also was running fine. But till the time I decide to checkout
instead of some selected module (via GUI-not typed) the whole
repository   "."
Simply I invoke the Advanced Checkout dialog on the root of my emty 
JavaCVS FS. And just clicked OK (so there were by default the DOT in
modules textField).
And I receive exactly what you mentioned, Gilli.

I could checkouted selected modules, but not "." Till I didn't typy
specified file. In my case it was:
From that time it started to work. It lasts to work even after I
unmount my JavaCVS FS, deleted its content outside of ide and mounted
again and performed as the realy first command
checkout "."

Than it used to work till now... I can't explane what happend 
I hope that it isn't some sort of regresion:-(

Milos, do you have any exlanation for that?

Comment 7 dmladek 2002-08-26 08:58:00 UTC
Just for case (you've already know my cfg:)
RH72, sun jdk1.4.1 beta (know #b19) , sometimes jdk1.4.0_0x
and it was happening on unix cvs psrv... 1.11.2
Comment 8 _ gtzabari 2002-09-04 12:54:50 UTC
So do we know what's causing this or do you need any more info from my
Comment 9 Martin Entlicher 2002-09-04 15:19:24 UTC
Well, the thread trace of the exception would be valuable. Without it
I can hardly find what went wrong. I hope, that the exception body
would be least in the ide.log. Please try to find it there or attach
the ide.log.
Comment 10 Milos Kleint 2002-09-05 02:18:17 UTC
Martin, check ErrorLogPanel class, I think the exception is not logged
to the ide.log file, but rather only the exception's localized name is

what is indeed interesting and why I suggest that it's the server's
fault somehow are these last lines from server:
Clear-sticky jsp/
Clear-static-directory jsp/

As can be seen the doubleslash is coming from SERVER.

I wonder if the same in+out logs are generated for the command-line

Comment 11 Martin Entlicher 2002-09-05 12:42:57 UTC
Thanks Milos, I'll modify the ErrorLogPanel to print the exception
body to the ide.log.

I think I know now what has caused this and issue #26827.

You have in your CVSROOT/modules these lines:
classes      /classes
jsp          /jsp

And this is the source of the problem. There should be:
classes      classes
jsp          jsp

The leading slash is wrong and confused the server.

If I tried to set module Martin as:
Martin       /Martin

I got: D:\apps\vcs\cvs\repository/Martin does not match
cvs server: ignoring module Martin

which is exactly the same error as reported in issue #26827 in the
input log attached (id=7263).

Please correct your CVSROOT/modules file.
Resolving as invalid.
Comment 12 _ gtzabari 2002-09-05 13:46:49 UTC
Sounds to me like you're right. Is it possible to change this issue
into an enhancement and have Netbeans "suggest" a solution to this
exception when it pops up? Explanation exactly what you just said now?
Comment 13 Martin Entlicher 2002-09-05 14:14:48 UTC
Well, I agree, that sometimes are the error messages posted from the
server hard to understand and figure out what's actually wrong. Thus
it would be handy to have some internal "translator" from server
messages to user-understandable messages.

On the other hand there is no guarantee, that the server messages will
not change, which would cause this concept to stop working.

However in this case it seems that we can easily detect the double
slashes. I'll change it to the enhancement, but it will probably not
be implemented into 4.0, since there is a lot of other things to do.