This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 26660 - failures
Summary: failures
Alias: None
Product: platform
Classification: Unclassified
Component: Window System (show other bugs)
Version: 3.x
Hardware: PC Linux
: P3 blocker (vote)
Assignee: mslama
Keywords: TEST
Depends on:
Blocks: 20153
  Show dependency tree
Reported: 2002-08-20 21:35 UTC by Jesse Glick
Modified: 2008-12-23 09:45 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:

Log displaying failures (7.35 KB, text/html)
2002-08-20 21:36 UTC, Jesse Glick
Failure log (5.34 KB, text/html)
2002-10-17 21:38 UTC, Jesse Glick
Log (4.32 KB, text/html)
2002-10-21 15:14 UTC, mslama
Log file from test (might be useless) (195.02 KB, text/plain)
2002-10-21 18:10 UTC, Jesse Glick
The requested log file (12.13 KB, text/plain)
2002-10-21 21:05 UTC, Jesse Glick
Enriched log file (15.41 KB, text/plain)
2002-10-22 18:56 UTC, Jesse Glick
'Correct' log (14.67 KB, text/plain)
2002-10-23 09:18 UTC, mslama
Patch for winsys (79.25 KB, application/octet-stream)
2002-10-23 12:34 UTC, mslama

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2002-08-20 21:35:50 UTC
I get two consistent failures in this test case,
for a while now in dev sources. Attaching log.
Comment 1 Jesse Glick 2002-08-20 21:36:30 UTC
Created attachment 7148 [details]
Log displaying failures
Comment 2 Jesse Glick 2002-08-20 21:38:01 UTC
Please either fix a bug if there is one, make tests more robust, or
remove the test methods from the stable config if they cannot be fixed.
Comment 3 mslama 2002-10-10 12:29:31 UTC
I cannot reproduce it. From log it seems that incorrect TopComponent
is activated when menu is retrieved from DockingAction. So I added
check if right TopComponent is activated and if not activation is
performed more times (actually 4 times) and if even after that right
TopComponent is not activated test fails.
Comment 4 pzajac 2002-10-16 12:29:14 UTC
Tests passed now. 
Comment 5 Jesse Glick 2002-10-17 21:36:10 UTC
Actually I consistently get a different failure now.
Comment 6 Jesse Glick 2002-10-17 21:38:01 UTC
Created attachment 7696 [details]
Failure log
Comment 7 mslama 2002-10-21 15:13:44 UTC
Please test now, I added logging what TopComponent is activated during
test and also increased number of attempts to activate test TopComponent.

I have one additional problem: I overwrote method getName() in test
TopComponent defined in test and I get informational exception from
serialization of this TopComponent. I attach log.
Comment 8 mslama 2002-10-21 15:14:36 UTC
Created attachment 7716 [details]
Comment 9 mslama 2002-10-21 15:15:47 UTC
Is this exception important or can I ignore it?
Comment 10 Jesse Glick 2002-10-21 16:17:16 UTC
The exception looks like it might be significant. Maybe Jan knows
about it?
Comment 11 Jesse Glick 2002-10-21 18:09:45 UTC
Still fails for me in trunk. I don't know where you added this
logging, but XTest does not seem to preserve logfiles from tests run
in ide mode. Please let me know which specific file under
nb_all/xtest/instance/results/ you would like to see running
nb_all/xtest/instance/build.xml; I don't see anything relevant. (The
log for core unit tests shows details for code-mode tests, but for
ide-mode tests it shows only that NB was started, and a couple of
stack traces.) Will attach my core_unit.log just in case it is helpful.
Comment 12 Jesse Glick 2002-10-21 18:10:40 UTC
Created attachment 7722 [details]
Log file from test (might be useless)
Comment 13 mslama 2002-10-21 18:37:19 UTC
Not this. Go to test bag output -> IDE log -> output -> output from
Ant runner eg.
It contains all logs from tests. (Unfortunately ide.log itself does
not contain these logs.)
Comment 14 Jesse Glick 2002-10-21 21:05:36 UTC
Created attachment 7727 [details]
The requested log file
Comment 15 mslama 2002-10-22 09:59:42 UTC
Please try again. I added logging of all TopComponents/Modes on
current workspace. It is strange that TopComponent 'A' is activated.
There should be no such TopComponent. What configuration do you use? I
have no idea why requestFocus() fails on your machine.
Comment 16 Jesse Glick 2002-10-22 18:56:20 UTC
Created attachment 7738 [details]
Enriched log file
Comment 17 Jesse Glick 2002-10-22 19:18:19 UTC
I run Linux, 2.4.7 kernel, Sawfish WM with sloppy focus, running tests
under JDK 1.3.1_03.

I tried running just APITests by itself several times, using JDK 1.4.
Sometimes it passed, sometimes it failed ("could not activate right

Possible explanation: I routinely minimize test windows that are
popped up during an XTest run. ide-mode tests are generally annoying;
I run tests every day, but I have other things to do than turn on my
screensaver and go for coffee whenever they are running (10-15 min).
They pop up unsolicited windows while I am trying to read mail, etc.
Since my request to have MDI mode be used consistently for ide-mode
tests was rejected (issue #20829, and issue #16297 not effectively
implemented since non-editor-mode components appear as separate
frames), it is even worse: some tests (e.g. property sheet) open a
long string of new windows. So I am in the habit of minimizing all of
them as they appear to get them out of the way. Probably tests which
rely on details of which component has input focus etc. would be
sensitive to minimization.

Any suggestions? If not, mark FIXED or WORKSFORME or whatever.
Comment 18 mslama 2002-10-23 09:16:43 UTC
I tried to minimize main window and it has no effect on my machine.
But from your log there is no mode 'TestTopComponent'. It is strange.
It seems that creating new mode fails from unknown reason. I attach my
log. In test is called -> TopComponentManager is
responsible for creating new mode for TopComponent. Let me know if you
want to investigate it further. I will prepare patch with logging for
Comment 19 mslama 2002-10-23 09:18:26 UTC
Created attachment 7739 [details]
'Correct' log
Comment 20 mslama 2002-10-23 12:32:49 UTC
I prepared patch to log when TopComponentManager.doOpen() method is
entered and when new mode is created for test TopComponent. Log for
this appears on console where you run ant from.
Comment 21 mslama 2002-10-23 12:34:21 UTC
Created attachment 7752 [details]
Patch for winsys
Comment 22 Jan Pokorsky 2002-10-30 13:40:21 UTC
Regards to IllegalAccessException. It should not hurt anything. Java
beans use to declare getName/getDisplayName a public access modifier
usually. But for sure, please file a bug against the openide/settings
to treat that case. Thanks.
Comment 23 Jesse Glick 2002-11-29 16:35:53 UTC
Are you still waiting for some info from me? I mostly forgot about
this. I still see 2 winsys test failures regularly: fail Could not
activate right TopComponent. error try
to access class from class
Comment 24 mslama 2002-12-05 14:59:33 UTC
I fixed issue #28097 (TCRef interface is set back to public). I am not
able to reproduce this issue. In your environment there are some
components whcih should not be there. Marian did you see this problem
on test machines? I close this issue. Jesse if you want to investigate
it further reopen it.
Comment 25 Jesse Glick 2002-12-06 00:02:59 UTC
I don't really have the ability to investigate it more - I don't know
the code - so if you cannot fix the test, please exclude it from the
stable config. You can run it manually to verify certain changes if
you want to. I would like to have 100% of tests pass, and this is one
of three regular failures I get.
Comment 26 mslama 2002-12-09 13:38:18 UTC
Ok I will split test and exclude failing tests from stable config.
Comment 27 mslama 2002-12-09 14:02:36 UTC
Fixed in main trunk.
Comment 28 Marian Mirilovic 2003-01-15 13:45:29 UTC