This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 269320 - NullPointerException at org.netbeans.modules.testng.ant.TestNGOutputReader.testTaskFinished
Summary: NullPointerException at org.netbeans.modules.testng.ant.TestNGOutputReader.te...
Status: NEW
Alias: None
Product: java
Classification: Unclassified
Component: TestNG (show other bugs)
Version: 8.2
Hardware: All All
: P3 normal with 1 vote (vote)
Assignee: Theofanis Oikonomou
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-13 14:13 UTC by skygo
Modified: 2017-05-03 14:11 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 227534


Attachments
stacktrace (2.12 KB, text/plain)
2016-12-13 14:13 UTC, skygo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description skygo 2016-12-13 14:13:02 UTC
Build: NetBeans IDE 8.2 (Build 201609300101)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.122-b01, Java(TM) SE Runtime Environment, 1.8.0_122-ea-b01
OS: Windows 10

User Comments:
skygo: unclear what lead to this exception




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.testng.ant.TestNGOutputReader.testTaskFinished(TestNGOutputReader.java:799)
   at org.netbeans.modules.testng.ant.TestNGAntLogger.taskFinished(TestNGAntLogger.java:221)
   at org.apache.tools.ant.module.bridge.impl.NbBuildLogger.taskFinished(NbBuildLogger.java:564)
   at org.apache.tools.ant.Project.fireTaskFinished(Project.java:2223)
   at org.apache.tools.ant.Task.perform(Task.java:364)
   at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:68)
Comment 1 skygo 2016-12-13 14:13:04 UTC
Created attachment 163219 [details]
stacktrace
Comment 2 jrielsky 2017-05-03 14:11:43 UTC
This happened to me at about the same time I received a "Low Memory" warning in Netbeans 8.2.  I tried clean rebuild and restart and this does not clear the problem.  I am able to create a new TestNG test case Tools->Create/Update Tests for another java file in the project.  The resulting test case can be run and debugged.  However, any existing test cases still receive the same NPE when attempting to debug.  

Is there any workaround for this problem?