This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 28096 - FileSets bound to a JNDI name are not saved after they are altered
Summary: FileSets bound to a JNDI name are not saved after they are altered
Status: CLOSED FIXED
Alias: None
Product: projects
Classification: Unclassified
Component: Generic Infrastructure (show other bugs)
Version: 3.x
Hardware: All All
: P2 blocker (vote)
Assignee: Jan Pokorsky
URL:
Keywords:
Depends on: 23289
Blocks:
  Show dependency tree
 
Reported: 2002-10-17 21:40 UTC by Svata Dedic
Modified: 2004-04-19 16:17 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
Trace of project wizard execution (10.39 KB, text/plain)
2002-10-17 21:41 UTC, Svata Dedic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Svata Dedic 2002-10-17 21:40:21 UTC
Please see the attachde trace file. I have put 
Thread.dumpStack() into 
DataObjectFileSet.writeObject() and a message in 
JavaSourceComponent, just before thatFileSet.add(). 
I expected another save message to appear for the 
modified fileset, but that has not happened even 
when I closed the project and shut down the IDE. 
 
To reproduce: 
- Invoke New Java Application Project Wizard 
- Let the Wizard add (and create) `src' directory 
for sources 
- Hit Finish button
Comment 1 Svata Dedic 2002-10-17 21:41:52 UTC
Created attachment 7698 [details]
Trace of project wizard execution
Comment 2 Jan Pokorsky 2002-10-18 09:51:38 UTC
Aha, it is caused by changing PropertyChangeListener to
ContentListener in filesets. I'll try to work around until new
fileset's convertors will be ready.
Comment 3 Jan Pokorsky 2002-11-08 21:13:53 UTC
Content class implements a property change support to be able to
propagate changes to a serialdata convertor.

Worked around in

/cvs/projects/filesets/build.xml
new revision: 1.1.2.10; previous revision: 1.1.2.9
/cvs/projects/filesets/src/org/netbeans/api/filesets/Content.java;
new revision: 1.1.2.2; previous revision: 1.1.2.1
Comment 4 Jan Pokorsky 2003-02-11 20:57:54 UTC
Reverted the workaround. Fileset's convertors are ready.
Comment 5 Jan Becicka 2003-08-21 15:10:37 UTC
Verified
Comment 6 Jan Becicka 2003-11-25 14:21:25 UTC
As described in
http://www.netbeans.org/servlets/ReadMsg?msgId=619519&listName=nbdiscuss the
current work on projects prototype has been stopped.

Marking issue as CLOSED.