This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 29935 - ide-mode tests frequently hang at startup
Summary: ide-mode tests frequently hang at startup
Alias: None
Product: platform
Classification: Unclassified
Component: -- Other -- (show other bugs)
Version: 3.x
Hardware: PC Linux
: P2 blocker (vote)
Assignee: Jesse Glick
Keywords: THREAD
Depends on: 27330
  Show dependency tree
Reported: 2003-01-10 07:36 UTC by Jesse Glick
Modified: 2008-12-22 21:27 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:

Sample end of log file at time of hang, before killing it (8.47 KB, text/plain)
2003-01-10 07:37 UTC, Jesse Glick
Thread dump (8.31 KB, text/plain)
2003-01-10 11:32 UTC, L Martinek

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-01-10 07:36:27 UTC
Frequently, but unpredictably, ide-executor tests
(always in core in think? or maybe openide tests
too, not sure) will just hang at startup. I will
attach the end of a typical core_unit.log showing
a hang in testbag_5. Here the process mentioned
really exists:

13202 pts/1    SN     0:00
-Djdk.home=/space/jdk1.3.1_03 -classpath
-Xms24m -Xmx96m -Dnetbeans.logger.console=true
-Dxtest.includes= -Dxtest.excludes=
-Dtbag.patternset.exclude= -Dtbag.testtype=unit
-Dtbag.executor=ide -Dxtest.module=core
-Dxtest.attribs=stable -Dxtest.distexec=true
-Dnetbeans.full.hack=true -Dxtest.error.manager=true
org.netbeans.Main -nosplash

kill -QUIT 13202 has no apparent effect; at least
no thread dump appears in core_unit.log or
anywhere else I can find. Regular kill (-INT)
causes the process to terminate and XTest to end
the testbag.

The ide.log file in fact just ends with this stuff:

>Log Session: Friday, January 10, 2003 2:17:10 AM EST
>System Info: 

I have no idea why org.netbeans.core.TopLogging
would get this far and then quietly stop. Of
course I have only observed such hangs in XTest.
Comment 1 Jesse Glick 2003-01-10 07:37:57 UTC
Created attachment 8514 [details]
Sample end of log file at time of hang, before killing it
Comment 2 Jesse Glick 2003-01-10 07:38:54 UTC
I should mention that this happens to me often enough that I am
frequently unable to get the full NB test suite to run to completion
at all. So the P2 is justified from my perspective.
Comment 3 Martin Brehovsky 2003-01-10 11:22:35 UTC
We have noticed it in our regular test runs as well. The issue
appeared first when we started it after Chirstmas, last monday.
Ufortunately, from the XTest point of view, there was no change in
XTest harness I'm aware of. On our testing machines we were using old
XTest from the first half of December and still noticed these failures
since Christmas. 

So I'm afraid the problem is somewhere else than just in XTest ...
Fortunately, Libor was able to capture thread dump from one of our
machines and he will attach it to this report. Anyway, from the thread
dump it seems we have some deadlock problem (not caused by XTest IMO).
Can you look at it a bit closer? 
Comment 4 L Martinek 2003-01-10 11:32:32 UTC
Created attachment 8522 [details]
Thread dump
Comment 5 L Martinek 2003-01-10 11:38:19 UTC
I deleted library for native kill so ignore UnsatisfiedLinkError in
attached log. Immediatelly after dumping threads HotSpot error appeared.
Comment 6 Jesse Glick 2003-01-10 20:18:29 UTC
Ah, this is for me then. If I could have gotten the deadlock before I
could have fixed it much sooner... wonder why kill -QUIT was not working.
Comment 7 Jesse Glick 2003-01-10 22:19:55 UTC
I think I fixed it - hard to know for sure, but I more or less
understand the cause of the deadlink and I think this patch should
help. Reopen if you see it again, of course, preferably with a fresh
thread dump.

committed     Up-To-Date  1.91       
Comment 8 Marian Mirilovic 2004-03-05 22:36:39 UTC