This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 33894 - Inner Components property of a compiled javabean class cannot be accessible as individual component property.
Summary: Inner Components property of a compiled javabean class cannot be accessible ...
Status: RESOLVED DUPLICATE of bug 24843
Alias: None
Product: guibuilder
Classification: Unclassified
Component: Code (show other bugs)
Version: 3.x
Hardware: PC Windows ME/2000
: P3 blocker (vote)
Assignee: issues@guibuilder
URL:
Keywords:
: 34521 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-05-26 13:01 UTC by avasha
Modified: 2005-05-16 16:41 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description avasha 2003-05-26 13:01:52 UTC
Form editor is simply not able to customize
components inside other components once the
compound component is a compiled class (i.e.
normal JavaBean).

for example : a panel having OK and Cancel button.
I made this as a bean and loaded in the Component
Palette.
When i click and drop the bean in the form , the
component inspector will show that bean instance
as a node , as it a panel obviously the
proprty sheet will be for JPanel. But my aim is to
bring in the component inspector those inner
components in that panel, so that i can change the
properties of inner component also using property
sheet.
Comment 1 Tomas Pavek 2003-07-31 15:23:27 UTC
*** Issue 34521 has been marked as a duplicate of this issue. ***
Comment 2 Tomas Pavek 2005-05-16 16:41:32 UTC
Rather see issue 24843 - which is likely a better way of handling this. Form
editor can hardly modify composed beans that were already compiled.

*** This issue has been marked as a duplicate of 24843 ***