This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 35337 - Code-autoformat is incorrect for assert()
Summary: Code-autoformat is incorrect for assert()
Status: RESOLVED DUPLICATE of bug 23508
Alias: None
Product: editor
Classification: Unclassified
Component: -- Other -- (show other bugs)
Version: 3.x
Hardware: PC OS/2
: P3 blocker (vote)
Assignee: issues@editor
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-08-08 03:35 UTC by _ gtzabari
Modified: 2007-11-05 13:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2003-08-08 03:35:46 UTC
dev build 200307280100
Sun JDK 1.3.1_02

  When I try to auto-format the following code:

  assert(pattern.rows[row].notes[note].sample!=null) :
"pattern #" + filePatterns[i].number + ",row #" +
row + ",note #" + note + ",sample #" +
filePatterns[i].rows[row].notes[note].sample;

   any text that follows it is indented, which is
incorrect since it is not the beginning of a block.
Comment 1 Martin Roskanin 2003-08-08 14:09:42 UTC
It is a duplicate of the issue #23508
Indentation engine treats this as a case label.

*** This issue has been marked as a duplicate of 23508 ***