This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 35587 - Automated or semiautomated imports management
Summary: Automated or semiautomated imports management
Status: RESOLVED DUPLICATE of bug 2196
Alias: None
Product: ide
Classification: Unclassified
Component: Code (show other bugs)
Version: 3.x
Hardware: All All
: P1 blocker (vote)
Assignee: Ondrej Rypacek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-08-21 10:52 UTC by mvinar
Modified: 2004-09-02 09:25 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mvinar 2003-08-21 10:52:13 UTC
User problem:
-----------------------------------
Manual management of imports, having to jump to
the beginning of the source file and back when an
import is to be added is unnecessary interruption
from the workflow. The IDE should be able to help.
The explicit complex imports management tool is
too heavyweight to help a lot here, as its use
also breaks the flow.

User need:
-----------------------------------
The user would benefit from having the imports
section of source files being managed
automatically or semiautomatically by the IDE.

Product requirement:
-----------------------------------
Implement automated or semiautomated (unobtrusive
assistance by the user) imports management.
Comment 1 vladmihaisima 2003-09-28 10:25:20 UTC

*** This issue has been marked as a duplicate of 2196 ***