This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 38272 - EditorCookie.close() is very slow
Summary: EditorCookie.close() is very slow
Status: RESOLVED FIXED
Alias: None
Product: utilities
Classification: Unclassified
Component: Properties (show other bugs)
Version: 3.x
Hardware: PC Linux
: P3 blocker (vote)
Assignee: Jan Stola
URL:
Keywords: PERFORMANCE
Depends on:
Blocks: 38273
  Show dependency tree
 
Reported: 2003-12-22 17:11 UTC by _ pkuzel
Modified: 2004-08-13 12:11 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
Call stack (2.52 KB, text/plain)
2003-12-22 17:31 UTC, _ pkuzel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ pkuzel 2003-12-22 17:11:36 UTC
because it wrongly calls StructHandler.reparseNow().

It slows down TODOs search process considerably.
Comment 1 _ pkuzel 2003-12-22 17:31:06 UTC
Created attachment 12653 [details]
Call stack
Comment 2 Marian Petras 2004-03-09 14:30:07 UTC
Confirmed.

It seems that the problem is that reparsing is forced even if no
change was made in the file being closed.
Comment 3 Jan Stola 2004-06-14 10:58:25 UTC
I noticed that TODO search no longer uses this method
(it access the properties files directly). However,
the code has been modified to invoke parsing only
on modified files.