This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 43608 - cannot create platform: file not normalized
Summary: cannot create platform: file not normalized
Status: RESOLVED DUPLICATE of bug 43587
Alias: None
Product: java
Classification: Unclassified
Component: Unsupported (show other bugs)
Version: 4.x
Hardware: PC Windows XP
: P2 blocker (vote)
Assignee: Tomas Zezula
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-20 11:52 UTC by David Konecny
Modified: 2007-09-26 09:14 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
exception (29.94 KB, text/plain)
2004-05-20 11:54 UTC, David Konecny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Konecny 2004-05-20 11:52:59 UTC
I get attached exception when try to add new
platform in platform manager.

java.lang.IllegalArgumentException: Parameter file
was not normalized. Was ::{20
D04FE0-3AEA-1069-A2D8-08002B30309D} instead of
D:\dev\stable\nbbuild\netbeans\bi
n\::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
        at
org.openide.filesystems.URLMapper$DefaultURLMapper.findFileObjectsInR
epository(URLMapper.java:246)
        at
org.openide.filesystems.URLMapper$DefaultURLMapper.getFileObjects(URL
Mapper.java:234)
        at
org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:162)
        at
org.openide.filesystems.FileUtil.toFileObject(FileUtil.java:312)
        at
org.netbeans.modules.java.platform.wizard.LocationChooser$PlatformFil
eView.isPlatformDir(LocationChooser.java:303)
Comment 1 David Konecny 2004-05-20 11:54:00 UTC
Created attachment 15029 [details]
exception
Comment 2 David Konecny 2004-05-20 11:55:42 UTC
Radek, please look at this too. The normalized path looks also pretty
wild.
Comment 3 Tomas Zezula 2004-05-20 12:53:56 UTC
Duplicate of FS issue.

*** This issue has been marked as a duplicate of 43587 ***