This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 44318 - Some fields left blank in JUnit Test from Existing Class template
Summary: Some fields left blank in JUnit Test from Existing Class template
Status: CLOSED FIXED
Alias: None
Product: java
Classification: Unclassified
Component: JUnit (show other bugs)
Version: 4.x
Hardware: PC Linux
: P3 blocker (vote)
Assignee: junit-issues@java
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-04 00:30 UTC by Jesse Glick
Modified: 2006-03-24 09:41 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2004-06-04 00:30:05 UTC
040603. I selected an NBM project and chose New ->
File -> JUnit -> Test for Existing Class. Browsed
in the class field and chose a class in my module.
The Created Test Class and Created File fields
were left blank.

I also am seeing some warnings from HotSpot (1.5.0
b51) on my console, so if you cannot reproduce,
that could be why.
Comment 1 Marian Petras 2004-06-15 16:40:39 UTC
Accepted.
Comment 2 Marian Petras 2004-06-15 19:05:15 UTC
fixed in the trunk (together with bugs #43621, #44202, #44051, #44320,
#44321)

changed files:

junit/src/org/netbeans/modules/junit/wizards/Bundle.properties   (1.3)
junit/src/org/netbeans/modules/junit/wizards/EmptyTestCaseWizardIterator.java
  (1.5)
junit/src/org/netbeans/modules/junit/wizards/EmptyTestStepLocation.java
  (1.4)
junit/src/org/netbeans/modules/junit/wizards/LocationPanel.java  
(deleted - last revision 1.3)
junit/src/org/netbeans/modules/junit/wizards/SimpleTestStepLocation.java
  (1.5)
junit/src/org/netbeans/modules/junit/wizards/StepProblemMessage.java 
 (1.1 - initial revision)
junit/src/org/netbeans/modules/junit/wizards/TestSuiteStepLocation.java
  (1.4)
junit/src/org/netbeans/modules/junit/wizards/TestSuiteWizardIterator.java
  (1.5)
junit/src/org/netbeans/modules/junit/wizards/Utils.java   (1.5)
Comment 3 dmladek 2004-06-16 11:27:32 UTC
I don't understand very much what's going on in this bug :-(

But if mentioned fields are class members then they are not generated
at all. Same for methods.

BTW: The generated test class has bad name:
eg. if I'm generating test class for Foo class (Foo.java)
In Wizard is shown that it will name as FooTest.java
But generated file is just Foo.java and class has corresponding name Foo


I have to reopen...

Comment 4 Marian Petras 2004-06-16 13:15:34 UTC
The bug report is about empty text fields in wizard "Test for Existing
Class". This bug was fixed.

Bad name of a generated class is another issue. I know about this bug.
It should be fixed in two hours.
Comment 5 Marian Petras 2004-06-16 13:59:19 UTC
Fixed the bug with bad name of the generated test class.

Files commited to the trunk. CVS revisions of modified files:

junit/src/org/netbeans/modules/junit:
    CreateTestAction.java   (1.22)
    wizards/SimpleTestCaseWizard.java   (1.4)
    wizards/SimpleTestCaseWizardIterator.java   (1.5)
    wizards/SimpleTestStepLocation.java   (1.7)
Comment 6 dmladek 2004-06-23 14:51:02 UTC
sorry for reopening ;-) Maybe I was confused because in that time it's
been fixed so I was looking for  other "fields" which was empty ;-)

OK, on  NBdev40 #200406230100