This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 45431 - Running application from within IDE
Summary: Running application from within IDE
Status: CLOSED DUPLICATE of bug 43194
Alias: None
Product: projects
Classification: Unclassified
Component: Generic Projects UI (show other bugs)
Version: 4.x
Hardware: PC Windows XP
: P3 blocker (vote)
Assignee: Petr Hrebejk
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-23 11:08 UTC by vtec
Modified: 2006-03-24 10:17 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vtec 2004-06-23 11:08:50 UTC
1] Project Properties of J2SE application should
allow to specify JVM parameters (e.g. -ea) for
running project's main class.
2] How to specify parameters (both JVM and program
parameters) for arbitrary class with main method
within the project? There should be even option to
have several "run configurations" for each such
class .
Comment 1 Jesse Glick 2004-06-23 13:36:44 UTC
Re. #1 - supported in project.properties but not yet in GUI.

Re. #2 - for such things, write Ant targets.

*** This issue has been marked as a duplicate of 43194 ***
Comment 2 Marian Mirilovic 2005-12-20 16:02:16 UTC
This issue was solved long time ago. Because nobody has reopened it neither
added comments, we are verifying/closing it now. 
If you are still able to reproduce the problem, please reopen. 

Thanks in advance.
Comment 3 vtec 2005-12-20 16:31:14 UTC
I am the original reporter of this RFE. There has not been done anything
regarding comfortable management of multiple run / test configurations within IDE.

I can only say:
1] IntelliJ have it implemented in a very nice way 
2] Oracle JDeveloper have it implemented in a very nice way 
3] Eclipse have it implemented in a very nice way 
4] X-Develop have it implemented in a very nice way 

Netbeans - go and edit build file ....