This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 45651 - A11Y: A11y problems in Select Resource Bundle dialog
Summary: A11Y: A11y problems in Select Resource Bundle dialog
Status: VERIFIED FIXED
Alias: None
Product: platform
Classification: Unclassified
Component: Window System (show other bugs)
Version: 4.x
Hardware: All All
: P3 blocker (vote)
Assignee: Milos Kleint
URL:
Keywords: SIMPLEFIX
: 45653 45655 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-06-28 16:06 UTC by Jaromir Uhrik
Modified: 2008-12-22 22:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2004-06-28 16:06:17 UTC
[20040622; j2sdk1.4.2_04]
Main menu Tools-> Internationalization
->Internationalize and press Browse button.
Following problems are in output of the a11y tester:
*****************************************
Tested Window title : Explorer [Sources]
*****************************************
-Components with no LABEL_FOR pointing to it :
   Class:
org.openide.explorer.view.TreeView$ExplorerTree {
 Tree View |  Tree view in fil
e selector }

-Components not reachable with tab traversal :
   Class:
org.openide.explorer.view.TreeView$ExplorerTree {
 Tree View |  Tree view in fil
e selector }
Comment 1 Ondrej Rypacek 2004-07-08 10:21:26 UTC
The dialog is provided by NodeOperation.select(...)
Comment 2 Marian Mirilovic 2004-08-02 13:11:45 UTC
mentioned dialog/window contains next issues :
- there is Select label and this label should  be set as a label for JTree
- Sources node is out of date :
----------------------
    + Sources 
            + Source Packages
            + Test Packages 

Comment 3 Ondrej Rypacek 2004-08-02 16:43:35 UTC
Sorry ,but I don't understand your comment. I reassigned it to openide
because the whole dialog, including the label and JTree is provided by
openide. Thus, it's IMHO openide's responsibility to correctly init
the components, i.e. set the label for the tree.
Or am I wrong?
Comment 4 Petr Nejedly 2004-08-03 09:05:23 UTC
Actually, openide provides only the API, impl is in class 
org.netbeans.core.windows.services.FileSelector
Comment 5 Petr Nejedly 2004-08-03 09:08:41 UTC
*** Issue 45655 has been marked as a duplicate of this issue. ***
Comment 6 Milos Kleint 2004-08-04 09:02:58 UTC
reassigning
Comment 7 Marian Mirilovic 2004-08-05 08:05:52 UTC
*** Issue 45653 has been marked as a duplicate of this issue. ***
Comment 8 Milos Kleint 2004-08-06 07:01:31 UTC
fixed - added labelFor
Comment 9 Jaromir Uhrik 2004-11-10 15:13:41 UTC
Following problems are still found with the a11y tester tool in build
200411091800 -> reopening issue.

 Components with no LABEL_FOR pointing to it :
   Class: org.openide.explorer.view.TreeView$ExplorerTree {  Tree View
|  Tree view in file selector }
 Components not reachable with tab traversal :
   Class: org.openide.explorer.view.TreeView$ExplorerTree {  Tree View
|  Tree view in file selector }
Comment 10 Milos Kleint 2004-11-26 10:16:34 UTC
most probably something wrong with the accessibility tool.

The label is there, points the BeantreeView, the treeview$explorertree
class is inner to the treeview.
When checking manually, the tree can be reached by tab traversal as well.

So everything is in order on the fileselector side as far as i'm
concerned. Petr N. any ideas?
Comment 11 Jaromir Uhrik 2005-01-21 14:18:17 UTC
Verified.