This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 45698 - Cancel of Rename or Move is only partial but not total
Summary: Cancel of Rename or Move is only partial but not total
Status: RESOLVED DUPLICATE of bug 45346
Alias: None
Product: editor
Classification: Unclassified
Component: Refactoring (show other bugs)
Version: 4.x
Hardware: PC Other
: P3 blocker (vote)
Assignee: issues@java
URL:
Keywords:
Depends on:
Blocks: 44713
  Show dependency tree
 
Reported: 2004-06-29 21:39 UTC by vbrabant
Modified: 2007-04-03 18:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vbrabant 2004-06-29 21:39:04 UTC
I have a class Main in the default package of my
project. I drag it with the mouse and drop it into
a nother package.
The refactoring assistant appears and I click on
Cancel.

The class stay in the other package, but can't be
compiled because package sentence is missing.

I use the Refactoring | Move to replace the class
into the default package, and I obtain an error
that says : 
Class "Main" already exists in the target package.
Comment 1 Martin Matula 2004-06-29 22:17:23 UTC
We know about this problem and it is already filed as a bug. The
problem is that the d'n'd move action moves the file - the refactoring
window that appears after that is just an automated suggestion for the
user's convenience. It is distinct from the file move operation (and
the title of the window says "Refactor code for *moved* files"), thus
cancelling it does not undo the file move (which is handled by
openide). Obviously, this is not very clear to users (this issue is
what we hear very often) so we are going investigate how to address
this better (see the original issue this is a duplicate of).

*** This issue has been marked as a duplicate of 45346 ***