This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 46913 - File chooser isn't very smart - keeps going to the wrong place
Summary: File chooser isn't very smart - keeps going to the wrong place
Status: RESOLVED DUPLICATE of bug 47737
Alias: None
Product: utilities
Classification: Unclassified
Component: Code (show other bugs)
Version: 4.x
Hardware: PC Windows ME/2000
: P3 blocker (vote)
Assignee: issues@utilities
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-04 22:19 UTC by Chris Kutler
Modified: 2005-09-05 10:13 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Kutler 2004-08-04 22:19:46 UTC
Most of the time when the file chooser appears, it
appears in My Documents directory. I repeatedly
have to make several clicks to point to my
development work space. 

The file chooser should eventually get the hint of
where my current work space is.
Comment 1 Jan Stola 2004-08-05 09:03:52 UTC
Please, could you be more specific. What filechooser do you
speak about (what action invokes it)? What behaviour would
you expect?
Comment 2 Chris Kutler 2004-08-10 00:48:54 UTC
It happens all over, but here are 2 examples that I ran into today.

1. In the Runtime window, right-click on Drivers and choose Add
Driver. Click Add. Browse to the directory where you put your drivers
and choose a driver. Complete the transaction. Now go back to add
another driver. The File Chooser opens up in My Documents again, and I
have to make several clicks to get back to the place where I keep my
drivers.

2. In the Project Properties window, select Packing Project and click
Add Jar/Folder. It opens in the My Documents folder. Go through the
actions and add a jar file. Now do it again. It opens in the My
Documents folder.

I suggest that the IDE be a little smarter. Your HIE might have some
good suggestions. Ideas are to open the file browser on the project
directory or to open on the directory that was last used for that action.

Comment 3 Jesse Glick 2005-08-09 02:54:42 UTC

*** This issue has been marked as a duplicate of 47737 ***