This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 48127 - Ability to -Xlint from Project Properties
Summary: Ability to -Xlint from Project Properties
Status: CLOSED DUPLICATE of bug 46995
Alias: None
Product: projects
Classification: Unclassified
Component: Generic Projects UI (show other bugs)
Version: 4.x
Hardware: PC Windows XP
: P3 blocker (vote)
Assignee: Petr Hrebejk
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-30 01:38 UTC by _ gtzabari
Modified: 2006-03-24 10:27 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2004-08-30 01:38:15 UTC
Project Properties -> Build -> Compiling Sources
gives the option of "Generate debugging info" and
"Report uses of deprecated APIs" but does not
provide -Xlint support. Please add it.
Comment 1 _ gtzabari 2004-08-30 01:38:40 UTC
DEFECT -> ENHANCEMENT.
Comment 2 _ gtzabari 2004-08-30 01:46:09 UTC
Workaround: insert <compilerarg line="-Xlint:unchecked"/> right after
the javac statement in build-impl.xml

Example: 

<target name="-init-macrodef-javac">
...
<javac ...>
<compilerarg line="-Xlint:unchecked"/>
<classpath>
...

Although I should point out this is a hassle, especially for those not
familiar with Ant or where Netbeans actually stores the Ant build
files. This issue is filed against the UI component because this sort
of thing really should be part of the Project Properties.
Comment 3 David Konecny 2004-08-30 10:45:57 UTC
First, editting directly build-impl.xml is wrong because as written at
the beginning of file it is regenerated by IDE whenever needed. Edit
build.xml instead - it uses new feature of Ant 1.6 that you can
override targets from build-impl.xml there.

Anyway, already fixed in issue 46995.

*** This issue has been marked as a duplicate of 46995 ***
Comment 4 Marian Mirilovic 2005-12-20 16:02:19 UTC
This issue was solved long time ago. Because nobody has reopened it neither
added comments, we are verifying/closing it now. 
If you are still able to reproduce the problem, please reopen. 

Thanks in advance.