This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 52124 - HTML context menu - missing RunFile & View action
Summary: HTML context menu - missing RunFile & View action
Status: CLOSED FIXED
Alias: None
Product: web
Classification: Unclassified
Component: HTML Editor (show other bugs)
Version: 4.x
Hardware: All All
: P3 blocker (vote)
Assignee: Martin Krauskopf
URL:
Keywords: SIMPLEFIX
: 54830 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-12-06 17:12 UTC by zikmund
Modified: 2009-05-18 10:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zikmund 2004-12-06 17:12:39 UTC
Build 200412011810 (RC2)

HTML file editor context menu - there are missing
RunFile and View actions (to be more consistent
with XML/JSP editor context menu). Both are
reachable from HTML file node context menu.
Comment 1 zikmund 2005-02-14 14:31:35 UTC
*** Issue 54830 has been marked as a duplicate of this issue. ***
Comment 2 Marek Fukala 2005-02-17 16:48:41 UTC
I will add these actions
Comment 3 zikmund 2005-02-23 15:36:59 UTC
Build 200501301900 - RunFile is not reachable from node context menu -
see issue 54218.
Comment 4 Martin Krauskopf 2005-02-23 15:40:14 UTC
I'll solve this as part of the issue 54218.
Comment 5 Martin Krauskopf 2005-02-23 23:51:22 UTC
Fixed together with issue 54218.

Checking in html/src/org/netbeans/modules/html/HtmlLoader.java;
new revision: 1.39; previous revision: 1.38
Checking in html/src/org/netbeans/modules/html/mf-layer.xml;
new revision: 1.8; previous revision: 1.7
Checking in
web/core/src/org/netbeans/modules/web/core/jsploader/JspLoader.java;
new revision: 1.20; previous revision: 1.19
Checking in
web/project/src/org/netbeans/modules/web/project/ui/resources/layer.xml;
new revision: 1.17; previous revision: 1.16
Comment 6 zikmund 2005-02-25 10:12:39 UTC
Verified in 200502241900.

Even DebugFile action was added. Its usage is debugging filters which
apply to the HTML request. Standalone HTML can't be debugged.