This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 54660 - "Server Registry" node should be renamed to "Servers"
Summary: "Server Registry" node should be renamed to "Servers"
Status: CLOSED FIXED
Alias: None
Product: serverplugins
Classification: Unclassified
Component: Infrastructure (show other bugs)
Version: 4.x
Hardware: All All
: P3 blocker (vote)
Assignee: Martin Schovanek
URL:
Keywords: SIMPLEFIX, UI
Depends on:
Blocks:
 
Reported: 2005-02-08 10:04 UTC by jrojcek
Modified: 2006-03-24 13:01 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jrojcek 2005-02-08 10:04:47 UTC
According to the spec, the "Server Registry" should be renamed 
"Servers"/
Comment 1 Sherold Dev 2005-02-11 16:54:40 UTC
Naming it "Servers" might be quite misleading, since there are also 
databases in the "Server Registry". "J2EE Servers" would be probably 
more convenient name that will be also consistent with what we've 
got in the Server Manager. 
Comment 2 jrojcek 2005-02-14 17:01:59 UTC
I think "Servers" is fine as long as we fix the order of nodes in Runtime window as shown 
in the spec:

Servers
Web Services
Databases
...
Comment 3 Sherold Dev 2005-02-18 13:35:11 UTC
Setting the TM to 4.1. 
Comment 4 Sherold Dev 2005-02-22 12:35:45 UTC
Please not that fixing this will require to fix also all the tests
which  refer directy to Server Registry node by its name.
Comment 5 Sherold Dev 2005-02-28 18:05:23 UTC
Server Registry node renamed to Servers. Updated hopefully all the 
bundles which were referring to the Server Registry node label. 
 
Please note that this fix does not change order of the registry 
children nodes - order of all nodes should be defined in the 
specification first. 
 
Reassigning this issue to QE to make the needed changes in tests. 
 
Commit log: 
 
Checking in ui/Bundle.properties; 
/cvs/j2eeserver/src/org/netbeans/modules/j2ee/deployment/impl/ui/Bundle.properties,v  
<--  Bundle.properties 
new revision: 1.19; previous revision: 1.18 
done 
Processing log script arguments... 
More commits to come... 
Checking in ui/actions/Bundle.properties; 
/cvs/j2eeserver/src/org/netbeans/modules/j2ee/deployment/impl/ui/actions/Bundle.properties,v  
<--  Bundle.properties 
new revision: 1.20; previous revision: 1.19 
done 
Checking in 
src/org/netbeans/modules/web/project/ui/wizards/Bundle.properties; 
/cvs/web/project/src/org/netbeans/modules/web/project/ui/wizards/Bundle.properties,v  
<--  Bundle.properties 
new revision: 1.48; previous revision: 1.47 
done 
Checking in 
ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/ui/wizards/Bundle.properties; 
/cvs/j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/ui/wizards/Bundle.properties,v  
<--  Bundle.properties 
new revision: 1.16; previous revision: 1.15 
done 
Processing log script arguments... 
More commits to come... 
Checking in 
utilities/src/org/netbeans/modules/j2ee/common/ui/wizards/Bundle.properties; 
/cvs/j2ee/utilities/src/org/netbeans/modules/j2ee/common/ui/wizards/Bundle.properties,v  
<--  Bundle.properties 
new revision: 1.8; previous revision: 1.7 
done 
Checking in 
registry/src/org/netbeans/modules/websvc/registry/netbeans/Bundle.properties; 
/cvs/websvc/registry/src/org/netbeans/modules/websvc/registry/netbeans/Bundle.properties,v  
<--  Bundle.properties 
new revision: 1.4; previous revision: 1.3 
done 
 
Comment 6 Petr Jiricka 2005-03-21 15:33:45 UTC
This was already fixed in code, marking as fixed. A defect in tests is not a bug.
Comment 7 zikmund 2005-07-13 16:17:11 UTC
Verified.