This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 56906 - auto format after code deleted and pasted
Summary: auto format after code deleted and pasted
Status: RESOLVED DUPLICATE of bug 111536
Alias: None
Product: editor
Classification: Unclassified
Component: Formatting & Indentation (show other bugs)
Version: 4.x
Hardware: PC Windows XP
: P2 blocker (vote)
Assignee: issues@editor
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-24 09:06 UTC by agctools
Modified: 2008-02-29 07:48 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description agctools 2005-03-24 09:06:58 UTC
i received the feature enhancement request from end users.

when a code block is deleted/pasted, the java editor uses the original code
format (alignment and indent). user has to re-format the code with right-click
menu or short-cut key. it is not so user-friendly.

the expected feature is to format code automatically when a code block is
deleted or pasted to editor.
Comment 1 Vitezslav Stejskal 2008-02-29 07:48:36 UTC

*** This issue has been marked as a duplicate of 111536 ***