This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 57156 - Cannot remap shortcut (Ctrl-B)
Summary: Cannot remap shortcut (Ctrl-B)
Status: RESOLVED DUPLICATE of bug 39593
Alias: None
Product: editor
Classification: Unclassified
Component: Key bindings (show other bugs)
Version: 4.x
Hardware: All All
: P3 blocker (vote)
Assignee: issues@editor
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-29 21:44 UTC by tkellerer
Modified: 2007-11-05 13:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tkellerer 2005-03-29 21:44:56 UTC
I wanted to map Ctrl-B to "Match Brace" (Using Tools->Options->Editor
settings->Global Key Bindings) and the options dialog will happily let me do
this. It gives no warning that Ctrl-B is already bound to "Edit -> Go to super
Implementation" and that the binding from the main menu cannot be overwritten. 
I haven't checked if this is true for other main menu shortcuts as well.

If this is intended behaviour, then the options dialog should warn the user that
the shortcut cannot be overwritten. If it's not then the new assignment should
work :)

This is with with daily 4.1 build: 200503242007
Comment 1 Martin Roskanin 2005-03-30 07:10:18 UTC
Already reported, thanks.


*** This issue has been marked as a duplicate of 39593 ***