This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 59529 - Bookmark toggle sometimes stops working ? - key binding procedure needs rework
Summary: Bookmark toggle sometimes stops working ? - key binding procedure needs rework
Status: RESOLVED DUPLICATE of bug 39593
Alias: None
Product: editor
Classification: Unclassified
Component: Key bindings (show other bugs)
Version: 4.x
Hardware: All All
: P3 blocker (vote)
Assignee: issues@editor
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-02 05:33 UTC by sviyer
Modified: 2007-11-05 13:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sviyer 2005-06-02 05:33:12 UTC
I remapped toggle bookmark to ctrl-B.

It was working in the first few sessions.

It is not working currently. So I removed the binding and re-bound it to ctrl-B;
still does not work.

Then it turns out it is mapped at the editor level to goto-super implementation
! (how come it worked the first few sessions is confusing ??)

Why does the tool/keyboard option allow me to map to Ctrl-B ?

It should either warn me and not do it or warn me and ask me if I want to remove
the binding at the editor level ?

Each time you have to manually check at different levels if a key is bound to
something else !!!

-------------------------------------------------------------------------------
>Log Session: Tuesday, May 31, 2005 11:47:19 AM NZST
>System Info: 
  Product Version       = NetBeans IDE 4.1 (Build 200505031930)
  Operating System      = Windows XP version 5.1 running on x86
  Java; VM; Vendor      = 1.5.0_02; Java HotSpot(TM) Client VM 1.5.0_02-b09; Sun
Microsystems Inc.
  Java Home             = G:\Program Files\J2SE5.0_02\jre
  System Locale; Encod. = en_NZ (nb); Cp1252
  Home Dir; Current Dir = K:\Documents and Settings\Administrator;
D:\ProgramFiles\Netbeans-4.1
  IDE Install; User Dir = D:\ProgramFiles\Netbeans-4.1\platform5; K:\Documents
and Settings\Administrator\.netbeans\4.1
  CLASSPATH             =
D:\ProgramFiles\Netbeans-4.1\platform5\lib\boot.jar;G:\Program
Files\J2SE5.0_02\lib\dt.jar;G:\Program Files\J2SE5.0_02\lib\tools.jar
  Boot & ext classpath  = G:\Program Files\J2SE5.0_02\jre\lib\rt.jar;G:\Program
Files\J2SE5.0_02\jre\lib\i18n.jar;G:\Program
Files\J2SE5.0_02\jre\lib\sunrsasign.jar;G:\Program
Files\J2SE5.0_02\jre\lib\jsse.jar;G:\Program
Files\J2SE5.0_02\jre\lib\jce.jar;G:\Program
Files\J2SE5.0_02\jre\lib\charsets.jar;G:\Program
Files\J2SE5.0_02\jre\classes;G:\Program
Files\J2SE5.0_02\jre\lib\ext\dnsns.jar;G:\Program
Files\J2SE5.0_02\jre\lib\ext\localedata.jar;G:\Program
Files\J2SE5.0_02\jre\lib\ext\sunjce_provider.jar;G:\Program
Files\J2SE5.0_02\jre\lib\ext\sunpkcs11.jar
  Dynamic classpath     =
D:\ProgramFiles\Netbeans-4.1\platform5\core\core.jar;D:\ProgramFiles\Netbeans-4.1\platform5\core\openide-loaders.jar;D:\ProgramFiles\Netbeans-4.1\platform5\core\openide.jar;D:\ProgramFiles\Netbeans-4.1\platform5\core\org-netbeans-swing-plaf.jar;D:\ProgramFiles\Netbeans-4.1\platform5\core\updater.jar;D:\ProgramFiles\Netbeans-4.1\nb4.1\core\org-netbeans-upgrader.jar;D:\ProgramFiles\Netbeans-4.1\nb4.1\core\locale\core_nb.jar;D:\ProgramFiles\Netbeans-4.1\ide5\core\org-netbeans-modules-utilities-cli.jar
-------------------------------------------------------------------------------


Frustrating.
But NB still rocks.
Cheers
Comment 1 Martin Roskanin 2005-06-30 10:06:01 UTC
Yes, already known problem:
If you bound IDE global keybinding (via Tools/Keyboard Shortcuts), there is no
check for the keystroke already used in editor specific shortcuts
(Tools/Options/Editing/Editor Settings/ <and its subnodes> / keybindings/)
(and vice versa)
The keybindings definied in editor is supreme to global keybindings if the focus
is in editor.
AFAIK, both keybindings dialogs sholud be unnified in the near future
Thanks for the report

*** This issue has been marked as a duplicate of 39593 ***