This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 62249 - Expand project tree to last known state when project is opened
Summary: Expand project tree to last known state when project is opened
Status: RESOLVED WORKSFORME
Alias: None
Product: projects
Classification: Unclassified
Component: Generic Projects UI (show other bugs)
Version: 7.3
Hardware: All All
: P3 blocker with 2 votes (vote)
Assignee: Tomas Stupka
URL:
Keywords:
: 147455 151920 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-08-13 20:39 UTC by Mark Dey
Modified: 2015-08-04 08:54 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Dey 2005-08-13 20:39:06 UTC
Issue 55701 addresses the restoration of the expanded state of open projects at
IDE startup. Performance issues aside, this is a desirable feature to have, but
it is not sufficient. Whenever a project is opened in the IDE, it is highly
desirable to have it shown in the project navigator in it's last known expanded
state.
Comment 1 Milan Kubec 2008-10-16 14:04:55 UTC
*** Issue 147455 has been marked as a duplicate of this issue. ***
Comment 2 thinker 2009-04-29 14:48:19 UTC
I just wanted to file an issue about that. In my project I need to click about 10-12 times to get opened my project
folder and libraries I use. So it's not about 2 clicks less.
Comment 3 Jesse Glick 2011-10-11 22:13:56 UTC
*** Bug 151920 has been marked as a duplicate of this bug. ***
Comment 4 Remdul 2013-09-23 20:10:56 UTC
This requested feature is as of version 7.3 still desirable. All competing IDEs I have used, have this feature.

I would also argue that this should be trivial to implement, at least for the tree displayed on the "Projects" tab. It would just be a boolean property attached to the logical folder tag in configurations.xml . E.g:

<logicalFolder name="f2" displayName="blah" projectFiles="true" unfold="true">

It would then require a minor change in the code that fills the tree control, to mark the item as unfolded.

I have actually implemented this very feature a number of times in the past, and found it to be an excellent "bang for buck" opportunity.


The trees on other tabs ("Files", "Classes") are a bit more volatile, so I (as end-user) would not expect the state to be remembered between sessions. I would consider this separately from the "Projects".
 Though I have previously implemented such a thing in my own software, by storing tree node states along with a hash of the node label text (or any other available unique node identifier). When restoring the tree state, you just loop the nodes and restore whatever possible, ignoring any mismatches/leftovers. This works fine 95% of the time.
Comment 5 UltraDev 2015-08-03 20:18:39 UTC
I want it too! Its soo needed when i have a few projects with huge file hierarchy.
Thanks!
Comment 6 Tomas Stupka 2015-08-04 08:54:00 UTC
seems like the described feature works in the last dev build.