This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 6393 - Help does not work in editor for several dialogs, windows and nodes
Summary: Help does not work in editor for several dialogs, windows and nodes
Status: CLOSED FIXED
Alias: None
Product: usersguide
Classification: Unclassified
Component: Editor (show other bugs)
Version: 3.x
Hardware: All All
: P3 normal (vote)
Assignee: David Konecny
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2000-04-20 16:34 UTC by Jan Lahoda
Modified: 2007-11-05 13:39 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
This is diff file of changes which should be commited into 3.2 version (13.98 KB, text/plain)
2001-07-20 20:48 UTC, David Konecny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Lahoda 2000-04-20 16:34:20 UTC
Try to call help in Abbreviations or Global key bindings dialog.
It will show some generic page and not help for the dialog.

Abbreviations: Tools=>Gobal Options=>Editor Settings=>Java Editor=>Abbreviations
Global key bindings: Tools=>Gobal Options=>Editor Settings=>Global key settings
Comment 1 Marek Grummich 2000-07-25 09:08:59 UTC
Priority is changed to P4 (normal).
Comment 2 Jan Lahoda 2001-01-24 15:38:59 UTC
Only changed version to Development.
Comment 3 Petr Nejedly 2001-02-07 15:27:59 UTC
The missing help bindings have the following help IDs

JavaHelp topic ID org.netbeans.modules.editor.options.KeyBindingsEditor
JavaHelp topic ID org.netbeans.modules.editor.options.AbbrevsEditor

Also, there is no mapping for find/replace dialog and goto dialog:
org.netbeans.editor.ext.GotoDialogPanel
org.netbeans.editor.ext.FindDialogSupport$FindPanel
Comment 4 Jan Chalupa 2001-03-12 10:37:19 UTC
Version: 'Dev' -> 3.2
Comment 5 David Konecny 2001-04-13 13:53:21 UTC
Here is the list of all HelpIDs for Editor:

Dialog Boxes                          HelpID
----------------------------------------------------------------
Editor Find                           editing.find
Editor Replace                        editing.find
Update Parser Database                editing.parserdatabase
Add Shortcut Sequence                 editing.csh.shortcutseq
GoTo                                  editing.goto
Fast Import                           editing.fastimport
Fast Open                             editing.fastopen
Recorded Macro                        editing.macros.recording
Enter Macro                           editing.macros.editing
Enter Abbreviation                    editing.abbreviations

Property Editors                      HelpID
----------------------------------------------------------------
Key Bindings                          editing.keybindings
Macros                                editing.macros.editing
Abbreviations                         editing.abbreviations
Simple Indentation Engine             editing.indentation.simple
Java Indentation Engine               editing.indentation.java
Scroll Insets Property Dialog         editing.scrollinsets
Fonts & Colors                        editing.fonts

Nodes, Subnodes                             HelpID
---------------------------------------------------------------------
Global Editor Settings                      editing.global
Java Editor Settings                        editing.editor.java
HTML Editor Settings                        editing.editor.html
Plain Editor Settings                       editing.editor.plain
JSP Editor Settings                         editing.editor.jsp
Properties Editor Settings                  editing.editor.properties
Indentation Engines                         editing.indentation
Printing Subnodes                           editing.printing
Printing Node                               editing.printing

Windows                                      HelpID
---------------------------------------------------------------------
Source Editor window                         editing.editorwindow
Code Completion Popup Window                 editing.codecompletion

Some of these IDs must be fixed in other modules:
Web module:
 JSP Editor Settings                         editing.editor.jsp

Properties module:
 Properties Editor Settings                  editing.editor.properties

OpenIDE,Core:
 Indentation Engines                         editing.indentation
 Printing Node                               editing.printing
 Source Editor window                        editing.editorwindow
Comment 6 David Konecny 2001-04-13 13:58:04 UTC
Created attachment 1107 [details]
This is diff file of changes which should be commited into 3.2 version
Comment 7 Peter Zavadsky 2001-04-13 15:57:01 UTC
For properties module part -> editing.editor.properties.

Fixed in [main-trunk].
Comment 8 Peter Zavadsky 2001-04-17 10:36:56 UTC
For properties module part -> editing.editor.properties.

Fixed in [release32] too.
Comment 9 David Konecny 2001-04-17 14:26:32 UTC
All HelpIDs (in Editor, Core, Properties and Web) should be OK now.

Fixed in both 3.2 and main trunk. Thanx all for cooperation.
Comment 10 Jan Chalupa 2001-05-05 22:09:23 UTC
Target milestone -> 3.2
Comment 11 Jan Lahoda 2001-11-01 14:45:43 UTC
Hi,
   in 200111010100:
It happens in following dialog/property editors/..., that incorrect
help is showed. But it is a bit strange, because I called help for
macros (F1), bad help was showed, did not closed the help window,
pressed Help button on dialog and good help was showed. I do not know
whether this applies to all mentioned helps.
I found following bad helps:
Font&Colors dialog 
Indentation engine's property editor (this is in core) Macros dialog
(works OK in Add... (macro))
Scroll * insets dialog
Keybindings/Add shortcut (for Keybindings dialog it is OK)
Tabs for Options/Editing/Editor settings/* editor
Fast import dialog
Replace dialog
Find dialog (help for editor is shown not for find)

Comment 12 David Konecny 2001-11-05 15:35:15 UTC
Brenda,

could you double check it please? I believe we did not change anything 
in source code and so I would say that problem should be in linking of 
help IDs into your help documentation. Let me know if I could help you 
somehow.

David

btw. I suggest to create new issue for 3.3 version. I think this one 
was successfully fixed for 3.2
Comment 13 Brenda Bowden 2001-11-08 02:19:12 UTC
This looks like a combination of different problems, with different
owners and resolutions.

For Fonts&Colors, Scroll * Insets, and Add Shortcut Sequence dialogs:

  These dialogs do not display interesting help because the help 
  pages haven't been written yet. This is likely to be fixed in 
  a 3.3.x release.  (The Scroll Insets help problem is bug 6004.)
  I take full responsibility for these problems.

For Indentation Engine and Macros dialogs:

  The help problems here seem to be a focus problem. These pages 
  show (in Nov. 7 build) correct help when using the 
  Help button or after clicking on one of the elements in the
  dialog and clicking F1.  But sometimes F1 doesn't work if 
  user hasn't first clicked on an element in the dialog.  David,  
  is this something that can be fixed on engineering's side?

For Fast Import dialog:

  I can't reproduce the problem.  F1 is always working for me.

For Replace dialog and Find dialog:

  Help is not working on these dialogs.  It did work in 3.2.  
  David, I haven't changed the map ids for these pages, so I'm
  not sure what else to do.  Can you double-check in the code 
  for these dialogs that they are hooked to the id editing.find?

I'm not sure what "Tabs for Options/Editing/Editor settings/* editor
is referring to. The editor nodes in the Options window are 
displaying the correct help page.  Is the problem somewhere else?



   
Comment 14 David Konecny 2001-11-08 14:35:20 UTC
Thanx Brenda. I'm going to check Find/Replace dialog and Honza 
promised to investigate the focus problems.

Assigning back to me.
Comment 15 Jan Lahoda 2001-11-08 15:01:32 UTC
I agree with David, that we should have new issues for a new release,
so I forked new issues for each problem here:

For Fonts&Colors, Scroll * Insets, and Add Shortcut Sequence dialogs:
I extended Issue #6004.

For Indentation Engine and Macros dialogs:
Created a Issue #17424

For Fast Import dialog:
My mistake, it works OK. Probably some bug in my notes.

For Replace dialog and Find dialog:
Forked a new Issue #17426 for it.

Options/Editing/Editor settings/* editor
First, I will explain what I meant by this. If you will select the
Tools/Options/Editing/Editor settings/Java editor node and click on
the property sheet tab and invoke help via F1, generic page is shown.
I looked over options, and only very rare cases have some particular
help for the tabs. So, if you think there should not be help aviable,
close directly this bug, else fork a new bug for this and close this
one please.

Thank you for investigation.
Comment 16 David Konecny 2001-11-09 10:08:05 UTC
I'm closing this bug. Probably the help for tabs is not necessary. If 
you think it is, the separate issue must be filed and help should be 
added to all tabs in IDE for the consintency's sake.
Comment 17 Jan Lahoda 2001-11-12 13:11:02 UTC
Marking as closed, all new problems for 3.3 and subsequent releases
should go into separete issues.