This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 65540 - Refactoring doesn't work for JSF beans
Summary: Refactoring doesn't work for JSF beans
Status: VERIFIED FIXED
Alias: None
Product: javaee
Classification: Unclassified
Component: JSF (show other bugs)
Version: 5.x
Hardware: PC Windows XP
: P3 blocker (vote)
Assignee: Petr Pisl
URL:
Keywords:
: 73725 76467 (view as bug list)
Depends on:
Blocks: 64092
  Show dependency tree
 
Reported: 2005-09-30 15:53 UTC by Petr Blaha
Modified: 2006-06-26 16:02 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Blaha 2005-09-30 15:53:05 UTC
[build 20050928]
Steps:
1) have web module with JSF bean
2) invoke Rename/Move refactoring actions for bean node
ERROR: changes are done in faces-config file
Comment 1 Petr Pisl 2005-10-24 16:38:43 UTC
We are not going to do refactoring features for jsf in nb 5.0 timeframe.
Comment 2 Petr Blaha 2006-03-20 09:17:50 UTC
*** Issue 73725 has been marked as a duplicate of this issue. ***
Comment 3 Pavel Buzek 2006-05-17 14:09:37 UTC
*** Issue 76467 has been marked as a duplicate of this issue. ***
Comment 4 Pavel Buzek 2006-05-17 14:11:13 UTC
The issue is now much easier to solve with EL support. Petr will try to make it
for 5.5 if possible.
Comment 5 Petr Pisl 2006-05-30 10:22:05 UTC
Refactoring for managed beans is now implemented.
Comment 6 Lukasz Grela 2006-06-26 16:02:14 UTC
v.