This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 65643 - [50cat] Impossible to find a difference between localized property bundles
Summary: [50cat] Impossible to find a difference between localized property bundles
Status: RESOLVED FIXED
Alias: None
Product: utilities
Classification: Unclassified
Component: Properties (show other bugs)
Version: 5.x
Hardware: PC Windows XP
: P3 blocker (vote)
Assignee: issues@utilities
URL:
Keywords:
Depends on: 48263
Blocks:
  Show dependency tree
 
Reported: 2005-10-02 20:18 UTC by jlaskowski
Modified: 2008-08-15 16:25 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jlaskowski 2005-10-02 20:18:51 UTC
[ BUILD # : 200509261930 ]
[ JDK VERSION : 1.5.0_05 ]

1. Create a project - New Project->General->Java Application (use the defaults)
2. Create a property file - New->Other->Properties File (use the defaults)
3. Add Locale
4. Add (another) Locale
5. Add Property to the one of the localized properties
6. Compare these two properties - Tools->Diff

The message: No difference were found between 'newproperties.properties' and 'newproperties.properties'. implies that these localized bundles aren't diff'ed properly.
Comment 1 _ pkuzel 2005-10-13 11:19:17 UTC
DiffAction uses:

  node.getLookup().lookup(FileObject.class)

followed by

  node.getCookie(DataObject.class).getPrimaryFile()

logic.
 
Properties module must be rewriten to supply FileObject in their nodes' lookups.
Comment 2 Marian Petras 2005-10-21 15:40:03 UTC
Accepted.
Comment 3 Marian Petras 2007-01-12 16:15:15 UTC
Caused by the fact that all localized property files are kept in one DataObject
- see issue #48263.
Comment 4 Tomas Pavek 2008-08-15 16:25:58 UTC
Just fixed as part of issue 42919.