This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 66520 - Installation fails with no error message on Solaris x86
Summary: Installation fails with no error message on Solaris x86
Alias: None
Product: installer
Classification: Unclassified
Component: Tools bundle (show other bugs)
Version: 5.x
Hardware: PC Solaris
: P1 blocker (vote)
Assignee: mslama
Keywords: RELNOTE
Depends on:
Reported: 2005-10-11 19:00 UTC by bakksjo
Modified: 2005-11-03 14:24 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:

installer log (1.30 KB, text/plain)
2005-10-12 11:42 UTC, Lukas Jungmann

Note You need to log in before you can comment on or make changes to this bug.
Description bakksjo 2005-10-11 19:00:37 UTC
I downloaded NetBeans 5.0 beta with AS8.1 from and tried to install
it on my laptop which has a fresh Solaris 10 installation.

The installation quits after the "Verifying JVM" step:

          Initializing InstallShield Wizard........
          Verifying JVM.

bash-3.00$ java -version
java version "1.5.0_01"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_01-b08)
Java HotSpot(TM) Client VM (build 1.5.0_01-b08, mixed mode)
Comment 1 Michal Mocnak 2005-10-12 09:38:11 UTC
I am not able to reproduce it. I've tried to install it on same configuration
and everything done well. Please try to use other JDK. You can run the installer
with  this switch: <installer> -is:javahome <path_to_jdk>
Comment 2 Petr Blaha 2005-10-12 11:15:48 UTC
Reporter, can you run installer with option -is:log logfile and attach the log
file? Thanks.
Comment 3 Lukas Jungmann 2005-10-12 11:23:47 UTC
I'm able to reproduce this with daily build - 200510111800 - on sol10-sparc
(s2). installer log is attached.
Comment 4 Lukas Jungmann 2005-10-12 11:42:55 UTC
Created attachment 25853 [details]
installer log
Comment 5 Lukas Jungmann 2005-10-12 11:45:48 UTC
forgot to say that JAVA_HOME environment property was set to /usr/java (jdk
Comment 6 Lukas Jungmann 2005-10-12 12:14:47 UTC
same result for nb+sjsas inst. bundle
Comment 7 mslama 2005-10-17 17:14:29 UTC
I reported it to InstallShield as bug. I found problem is caused by presence of
/bin in PATH. It is duplicate as /bin is link to /usr/bin. When /bin is in PATH
JVM resolution in installer launcher fails. Workaround is either to remove /bin
from PATH (it is not necessary as I said above) or use command line switch
-is:javahome <Path to JDK>. No need to set JAVA_HOME to reproduce this problem.
Comment 8 mslama 2005-10-17 17:21:12 UTC
I forgot to say I placed /bin as first item in PATH. Order of items could be
Comment 9 bakksjo 2005-10-18 09:00:02 UTC
I am puzzled by the fact that you simply closed this report.

I would like to remind you that this problem occurs on a vanilla Solaris 10

Do you actually suggest that in order to install NetBeans, a user (who might not
even have root access) should go ahead and remove the /bin symlink, which is
there by default in Solaris? I would feel very uneasy doing such a thing, not
knowing what the consequences would be. Also, how on earth would a user know to
proceed with ANY of the two workarounds you suggest? The installer simply
*exits*. No error message. How can the user know the problem is the /bin
symlink? And there is no hint to run with -is:javahome either.

This is bad user experience. People will not fiddle with this for a long time,
they will go ahead and download Eclipse instead. I guess you're happy with that?
Comment 10 bakksjo 2005-10-18 09:04:36 UTC
Sorry, I didn't mean removing the symlink, but moving /bin from PATH. From where
should the user get that idea? And why is the symlink a problem? The installer
should be able to figure it out - any other java program can easily be run
simply invoking 'java <program>', so why not the installer?
Comment 11 mslama 2005-10-18 16:37:52 UTC
I found simple workaround (Check of /bin is omitted in launcher.)
Comment 12 mslama 2005-10-20 10:29:24 UTC
Fixed. Michal please verify in new installer builds produced by RE. Today it
should be integrated by RE to build environment. Discuss with RE when it will be
ready. Thanks. 
Comment 13 Michal Mocnak 2005-11-03 14:24:10 UTC