This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 70764 - I18N - blueprint sample with webservice wont build if project in dir path with multibyte
Summary: I18N - blueprint sample with webservice wont build if project in dir path wit...
Alias: None
Product: obsolete
Classification: Unclassified
Component: blueprints (show other bugs)
Version: 6.x
Hardware: Sun All
: P2 blocker (vote)
Assignee: Yutaka Yoshida
Keywords: I18N, RELNOTE
Depends on:
Reported: 2005-12-23 07:24 UTC by Ken Frank
Modified: 2013-02-13 10:20 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:

output window info (4.25 KB, text/plain)
2005-12-23 07:26 UTC, Ken Frank
J2EE Client of Document Oriented Services (4.34 KB, text/plain)
2006-01-05 10:27 UTC, Marek Grummich
Standalone Client of Document Oriented Services (967 bytes, text/plain)
2006-01-05 10:29 UTC, Marek Grummich

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2005-12-23 07:24:32 UTC
Was trying out bluprints - 1 each of the 3 sample project types - ajax, web,
web services - running in asian locale.

for the one with web services, used the doc-attachment -
building it gave error in attachment in output window
if project lived in a dir path that had mbyte as part of it,
but if project lived in dirpath without mbyte, it built

the error message in output window refers to that an encoding
definition might be missing. 

messages.log has nothing related to this.
Comment 1 Ken Frank 2005-12-23 07:26:50 UTC
Created attachment 28049 [details]
output window info
Comment 2 Petr Jiricka 2006-01-03 13:16:18 UTC
Hi Ken,

we discussed this in Prague and we think that this could be waived for NB 5.0.
Would you agree?
Comment 3 Ken Frank 2006-01-03 20:34:40 UTC
Agree it can be waived if can be release noted - something like user should  not use
mbyte in project dir path ? Since these are samples and thus visible
to user, think that would be helpful.
Comment 4 Ken Frank 2006-01-03 20:38:04 UTC
Could someone in dev make sure that for regular ejb/j2ee project with web service,
similar to this, that path with mbyte is really ok; it seemed that way
in some testing but would like to be sure.
Comment 5 Yutaka Yoshida 2006-01-03 23:41:52 UTC
I tested several things and found out:-

o endpoint
  There's a bug in bpcatalog( which is not handling
  this case. This is easy to fix by just adding encoding="utf-8"
  when copying the wscompile config file.

o client
  We also have the same problem in the client side. It's not
  blueprints specific. To reproduce, do:-

  1. Projectize StringWebService from BluePrints solutions catalog
     and "Run" it.
  2. Create new project (web app) under the project location contains
     multi byte characters
  3. Do "New->Web Service Client"
  4. Set "http://localhost:8080/webservice/StringPurchaseOrderService?WSDL"
     in "WSDL URL", "Retrive WSDL"
  5. Enter a package name and hit "finish"

Then, you'll see the same error.
The problem is, generated nbproject/build-impl.xml has the code something like:-
<copy filtering="on"
       <filter value="${config_target}" token="CONFIG_ABSOLUTE_PATH"/>
The <copy> task must have encoding="UTF-8" as well.

I'll fix the endpoint side, and reassign to the appropriate party
once it's finished.

Comment 6 Yutaka Yoshida 2006-01-04 00:29:16 UTC
Fixed in the trunk.
Checking in external/;
/cvs/j2ee/external/,v  <--
new revision: 1.5; previous revision: 1.4
Again, this check-in only fixes the WS endpoing issue.
Comment 7 Yutaka Yoshida 2006-01-04 00:43:12 UTC
mark this as fixed.
- the issue on the client side should be reported separately.
Comment 8 _ ludo 2006-01-04 00:54:08 UTC
this fix is OK for me on the bp solution side.
Comment 9 Yutaka Yoshida 2006-01-04 02:09:47 UTC
integrated in release50.
Comment 10 Petr Blaha 2006-01-04 08:28:18 UTC
Ken, can you verify the fix? Thanks, Petr
Comment 11 Marek Grummich 2006-01-05 10:25:56 UTC
Build 200601042030
I tried to create (and run) all Java BluePrintSolutions, everything went well,
except following two:
J2EE Client of Document Oriented Services
Standalone Client of Document Oriented Services
(see attachments - output window)
Is this related to issue #70966?
Comment 12 Marek Grummich 2006-01-05 10:27:33 UTC
Created attachment 28196 [details]
J2EE Client of Document Oriented Services
Comment 13 Marek Grummich 2006-01-05 10:29:32 UTC
Created attachment 28197 [details]
Standalone Client of Document Oriented Services
Comment 14 Yutaka Yoshida 2006-01-05 22:36:06 UTC
Both clients are ok with the latest fix of 70966, but
there's a minor bug in stand alone swing client, which
may cause the "Run" error. I checked in the fix to the trunk.
Comment 15 Marek Grummich 2006-01-26 10:44:19 UTC