This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 72756 - Search indicator not stopping
Summary: Search indicator not stopping
Status: RESOLVED DUPLICATE of bug 72324
Alias: None
Product: utilities
Classification: Unclassified
Component: Search (show other bugs)
Version: 5.x
Hardware: PC Other
: P3 blocker (vote)
Assignee: Marian Petras
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-17 04:57 UTC by jwilliams
Modified: 2006-07-11 12:19 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jwilliams 2006-02-17 04:57:16 UTC
When a search is done from a node in the project window, the search activity
indicator in the bottom right corner of the screen does not stop, even after the
search is completed.

OS: Windows Server 2003
Comment 1 jwilliams 2006-06-07 04:15:45 UTC
After upgrading to NetBeans 5.5 beta, the problem is still occurring, but in
addition, I get an OutOfMemoryException dialog pop up after about 5 seconds.
Available memory should not be a problem as I have 4GB. However, it is a
relatively large project (with pre-existing ant script).
Comment 2 Marian Petras 2006-06-07 09:48:39 UTC
The amount of heap size available to NetBeans is not limited by amount of RAM in
your PC but by a hard limit of heap size given to the JVM on startup. The
default limit for NetBeans 5.x is 128 MB. If you get an OutOfMemoryError because
you have a large project, you need to increase this limit. See the following
FAQs for more information:

http://www.netbeans.org/kb/faqs/performance.html#FaqNetBeansAndOOME
http://www.netbeans.org/kb/faqs/performance.html#FaqSettingHeapSize
http://www.netbeans.org/kb/faqs/performance.html#FaqOutofMemoryOnCompile
Comment 3 Marian Petras 2006-07-11 12:19:38 UTC
This is a duplicate of bug #72324 ("Hanging progress handle").

*** This issue has been marked as a duplicate of 72324 ***