This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 74540 - renaming entity class didn't update namedQuerry
Summary: renaming entity class didn't update namedQuerry
Status: VERIFIED DUPLICATE of bug 73934
Alias: None
Product: javaee
Classification: Unclassified
Component: Refactoring (show other bugs)
Version: 5.x
Hardware: All All
: P3 blocker (vote)
Assignee: Erno Mononen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-06 20:06 UTC by Pavel Rehak
Modified: 2006-08-23 13:54 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Rehak 2006-04-06 20:06:02 UTC
Product Version         = NetBeans 5.5 Dev (Build 200604030200)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor; Home  = 1.5.0_06; Java HotSpot(TM) Client VM 1.5.0_06-b05;
Sun Microsystems Inc.; f:\Java\jdk-1_5_0_06\jre
  System Locale; Encoding = ja_JP (nb); MS932
-
i have created entity classes from database with pre-generated
@NamedQueries called by Entity name:
@Entity
@Table(name = "TRCUSTOMER")
@NamedQueries( {using @NamedQuery(name = "Trcustomer.findById"...
public class Trcustomer implements Serializable {

using Refactoring i renamed class name, but pre-generated NamedQueries
weren't updated.
Comment 1 Erno Mononen 2006-05-05 12:02:30 UTC

*** This issue has been marked as a duplicate of 73934 ***
Comment 2 Pavel Rehak 2006-08-23 13:54:25 UTC
Verified.