This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 75635 - IDE frozen after "Resolve Reference Problem"
Summary: IDE frozen after "Resolve Reference Problem"
Alias: None
Product: javaee
Classification: Unclassified
Component: Web Project (show other bugs)
Version: 5.x
Hardware: All All
: P1 blocker (vote)
Assignee: Martin Krauskopf
Depends on: 74204
  Show dependency tree
Reported: 2006-04-27 16:12 UTC by Marian Mirilovic
Modified: 2006-06-27 09:20 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:

thread-dump (31.17 KB, text/plain)
2006-04-27 16:13 UTC, Marian Mirilovic
Another thread-dump after second attempt to fix issue 74204 (29.47 KB, text/plain)
2006-05-02 15:58 UTC, Marian Mirilovic
75635-jmi-patch (11.00 KB, patch)
2006-06-08 09:35 UTC, Martin Krauskopf
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2006-04-27 16:12:35 UTC
NB 5.5 (200604270200), JDK 6.0 (b81)

Steps to reproduce:
- open web project (developed against non default JDK)
- after open , invoke from popup menu "Resolve Reference Problem"
- find appropriate JDK in the file chooser and push OK
-> IDE gets frozen forever (see attached thread-dump)
Comment 1 Marian Mirilovic 2006-04-27 16:13:13 UTC
Created attachment 30108 [details]
Comment 2 Martin Krauskopf 2006-04-28 08:19:36 UTC
MergedClassPathImplementation vs. ProjectManager.MUTEX fight again. Maybe dupe.
Need to elaborate more.
Comment 3 Marian Mirilovic 2006-04-28 14:35:28 UTC
I can't help myself, reproduced again 3 times / 3 attempts ;( 

BTW: I think this is stopper for Beta ...
Comment 4 Martin Krauskopf 2006-04-28 17:23:54 UTC
I would wait for evaluation of 74204. It's very similar. If they decide to not
to call ProjectManager.MUTEX under MergedClassPathImplementation lock a lot
would be solved including this one.
Comment 5 Marian Mirilovic 2006-05-02 15:58:18 UTC
Created attachment 30173 [details]
Another thread-dump after second attempt to fix issue 74204
Comment 6 Petr Blaha 2006-05-02 18:03:02 UTC
The bug isn't considered as Beta stopper. Therefore, I'm downgrading priority to P2.
Comment 7 Marian Mirilovic 2006-05-03 08:54:47 UTC
Petr it isn't JDK 6.0 issue, as you tried to explain yesterday. I reproduced
this with JDK 1.5.0_06 , NB Beta 5.5 (200605030200).

This is P1 for me, user has to restart the IDE to continue in the work,
therefore she can lost data, anyway as it's described in our Bugs Priority
Guidelines :

P1 :
crash or deadlock - Reproducible, unavoidable crash or deadlock
Comment 8 Martin Krauskopf 2006-06-06 13:45:40 UTC
I'll be working on it.... STARTED
Comment 9 Martin Krauskopf 2006-06-08 09:34:10 UTC
The attached patch contains a fix for MergedClassPathImplementation. It's based
on the one from Honza attached in issue 74204. There is also a simple test which
deadlocks with the original patch. Marian also tested it and it works so far.
Could anybody from javacore team (Honzo?) review the patch. I would then commit
into release55 branch.
Maybe we should also consider commiting it into trunk. Marian got the same
deadlock there.
Comment 10 Martin Krauskopf 2006-06-08 09:35:44 UTC
Created attachment 30884 [details]
Comment 11 Martin Krauskopf 2006-06-12 10:34:33 UTC
Should be "forward-ported" to trunk?

test/unit/; ->;; ->;
Comment 12 Marian Mirilovic 2006-06-13 14:44:55 UTC
verified in NB 5.5 (200606130200)

Martine, pleae backport this into the trunk as well, thanks in advance.
Comment 13 Marian Mirilovic 2006-06-23 11:39:40 UTC
this is still reproducible in trunk. Do you plan to fix this in trunk as well ?
Comment 14 Tomas Zezula 2006-06-23 12:15:10 UTC
I will backport the fix into trunk.
Comment 15 Tomas Zezula 2006-06-23 14:53:44 UTC
Integrated into trunk:

Checking in
new revision: 1.27; previous revision: 1.26
Checking in
new revision: 1.5; previous revision: 1.4
Comment 16 Marian Mirilovic 2006-06-27 09:20:40 UTC
verified in NB dev(200606261800)