This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 76641 - Completely Blank in IDE after using XGL
Summary: Completely Blank in IDE after using XGL
Alias: None
Product: platform
Classification: Unclassified
Component: Window System (show other bugs)
Version: 5.x
Hardware: PC Linux
: P3 blocker (vote)
Assignee: mslama
Keywords: RELNOTE
: 84570 86253 87712 (view as bug list)
Depends on:
Reported: 2006-05-21 01:17 UTC by jackysiu
Modified: 2008-12-22 12:02 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Note You need to log in before you can comment on or make changes to this bug.
Description jackysiu 2006-05-21 01:17:10 UTC
Dear Sir/Madam,

It is found that after using XGL inside the Linux (SUSE Linux 10.1), the IDE
window of netbeans 5.0 and 5.5 beta are completely in blank. 

Comment 1 Jiri Prox 2006-05-22 08:17:37 UTC
Does it happen only in NetBeans or in all java application. What version of JDK
do you use?
Comment 2 josephg2006 2006-05-22 09:36:09 UTC
I have been able to reproduce the bug in both Gentoo and on the Korora Live CD.
 Both Eclipse and and simple JFrames and JButtons seem to work fine.  In both
versions of netbeans ctrl+n launches the new project dialog box but nothing is
rendered in the box.  The startup splash screen renders correctly.   
Comment 3 josephg2006 2006-05-22 09:42:42 UTC
Searching around I have found several other forums that also indicate the same
problem.  Some have suggested that the issue is related to compiz.  However, I
have found that simply launching Xgl in a rootless session and then launching
netbeans in that session also produces the same bug. 

I have tried both sun-jdk- and sun-jdk-  Both seem to have the
same problem.  

Comment 4 josephg2006 2006-05-22 10:54:34 UTC
I tested the jfc SwingSet2, Java2D, and Metalworks demos under Xgl and all seem
to work correctly.  It really seems like a Netbeans specific problem.
Comment 5 josephg2006 2006-05-22 12:01:38 UTC
After looking into the problem further I discovered that I make the component
under the mouse temporarily (at least partially) appear:

./netbeans -J-Dawt.nativeDoubleBuffering=true

I hope this starts to help.

Comment 6 jackysiu 2006-05-22 19:38:29 UTC
Hi, jiriprox,

I encountered almost exactly same as josephg2006 mentioned. 

- Tested with Sun JDK 1.5.0_06. 
- Splash screen of netbeans could be rendered and displayed correctly. IDE
window is completely in blank.
- Other Java IDE environment tested like Rational Application Developer 6.0 and
JBoss IDE (based on Eclipse 3.x)
- Seems not related to compiz, even not starting it (I'm using in KDE), still
encounter this problem. The complete workaround need to restore back all
shortcuts and restore displaymanager to "Xorg".

I found that most XGL users encountered this kind of problems for some games.
Thus, is that possible caused by some native drawing APIs using by the netbeans IDE?

Comment 7 Marian Mirilovic 2006-05-22 21:02:15 UTC
Ok, could you try this switch :

Please let me know it works or not. Thanks in advance.
Comment 8 josephg2006 2006-05-22 21:20:30 UTC
That does not seem to resolve the problem.  I noticed no change in performance.
 I really appreciate the help.  I found that the Kororaa live CD (if you have
enough ram on which to install netbeans) is sufficient to test the netbeans
environment with various flags.  However I don't mind testing them.

Hopefully this helps.  

Comment 9 jackysiu 2006-05-23 05:27:50 UTC
./netbeans -J-Dawt.nativeDoubleBuffering=true

I only got several scroll bars appearing...cannot 
count as workaround
Comment 10 jackysiu 2006-05-23 05:36:19 UTC
./netbeans -J-Dawt.nativeDoubleBuffering=true -> Some scroll bars re-appear

./netbeans -J-Dsun.java2d.noddraw=true -> still completely blank
Comment 11 jackysiu 2006-05-23 05:36:33 UTC
./netbeans -J-Dawt.nativeDoubleBuffering=true -> Some scroll bars re-appear

./netbeans -J-Dsun.java2d.noddraw=false -> still completely blank
Comment 12 David Simonek 2006-05-23 10:06:40 UTC
jackysiu, please try to run SwingSet demo bundled in JDK demos - is it blank as
well? That way we can find if this is netbeans specific or more general - Swing
related problem. Thanks.
Comment 13 josephg2006 2006-05-23 11:09:44 UTC
I tested this already and found that all the JFC stuff I tested worked fine in Xgl. 

I tested the jfc SwingSet2, Java2D, and Metalworks demos under Xgl and all seem
to work correctly.  It really seems like a Netbeans specific problem.

Is there any clever rendering that Netbeans does.  From the earlier suggestions
it seems like some direct draw is used.  I should note that eclipse seems to
work fine under XGL.

Comment 14 David Simonek 2006-08-09 15:22:26 UTC
Nope, there is no clever painting in netbeans, we are using just standard swing

Could you try with newest development build (Milestone1 of 6.0 is enough) on JDK
1.6.0 (early access)? We did some little magic to prevent main window from
flickering on JDK 1.5 and older. I disabled this hack for 1.6, this in the only
thing I can think of that may cause problems...

Reporter, could you also attach messages.log from broken session to see if if
there are some exceptions etc? Thanks.
Comment 15 Marian Mirilovic 2006-09-12 13:14:36 UTC
*** Issue 84570 has been marked as a duplicate of this issue. ***
Comment 16 Marian Mirilovic 2006-09-12 13:15:06 UTC
Comments from issue 84570 :
After searching this issue, I found that using adding AWT_TOOLKIT=MToolkit in
the environment fixes this. Is it possible to do this automatically so that
netbeans just work out of the box?

Comment 17 andrut 2006-09-22 20:52:56 UTC
Adding AWT_TOOLKIT=MToolkit didn't help in my case.

But it helped when I removed 2 lines from file
'netbeans-5.0/platform6/lib/nbexec'. These are the lines:

 export J2D_PIXMAPS

I hope it helps.
Comment 18 seine 2006-10-10 13:30:38 UTC
Removal of the J2D_PIXMAPS commands works for me also.

Ubuntu 6.06 LTS, Xgl + Beryl 0.1
Comment 19 Marian Mirilovic 2006-10-25 15:09:34 UTC
*** Issue 87712 has been marked as a duplicate of this issue. ***
Comment 20 Marian Mirilovic 2006-11-07 08:40:53 UTC
*** Issue 86253 has been marked as a duplicate of this issue. ***
Comment 21 Karthikeyan Rajeswaran 2007-04-23 18:44:40 UTC
Some related references: (jdk bug marked as
fixed in JDK1.6U1). :

   ...Start NetBeans and... Oh. NetBeans just shows me a blank window. That's
not good. Google Google Google... Ah. I have XGL and Compiz eye candy installed.
This forum post gives the answer - run the Xnest nested X server, the icewm
window manager and then run NetBeans in the nested X session. Fair enough.
Ubuntu recommends Xephyr rather than Xnest, so I grab that, icewm and.. great -
we have NetBeans! [UPDATE: See this comment for a handy little script I wrote to
run NetBeans in a nested X session.] ...
Comment 22 David Simonek 2007-09-24 13:17:47 UTC
Passing to Marek, probably we should close this as wontfix, or is there anything more we can do?
Comment 23 mslama 2007-09-25 12:05:48 UTC
JDK problem. According to it was fixed in JDK 6u1.