Bug 81324 - "Search History" on package view should list only content of the package.
Summary: "Search History" on package view should list only content of the package.
Status: VERIFIED DUPLICATE of bug 91815
Alias: None
Product: versioncontrol
Classification: Unclassified
Component: Subversion (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker (vote)
Assignee: issues@versioncontrol
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-28 11:19 UTC by Peter Pis
Modified: 2007-01-12 14:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Pis 2006-07-28 11:19:37 UTC
NetBeans IDE Dev (Build 060727)
1.5.0_07; Java HotSpot(TM) Client VM 1.5.0_07-b03
Linux version 2.6.9-1.667 running on i386
en_US (nb); UTF-8

Steps:
(Have project with packages like "a -> NewClass", "a.b -> NewInterFace", "a.b.c
-> NewJPanel")
1. Open project under subversion control.
2. Switch to "Projects" view and select package "a". ("Tools | Options | General
| View Java Packages as = List")
3. Invoke "Subversion | Search History" action on it. 
4. "Search History" component shows, push "Search" button.

Actions invoked if "Java Packages View" is set to "List" should be performed
non-recursively. Even though subversion log command can't invoked
non-recursively, output should be filtered in this case.
Comment 1 Maros Sandor 2006-08-23 16:47:19 UTC
It is not trivial to filter it, we may try in the future.
Comment 2 Tomas Stupka 2007-01-04 15:49:18 UTC

*** This issue has been marked as a duplicate of 91815 ***
Comment 3 Peter Pis 2007-01-12 14:35:27 UTC
Verified.