This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 82425 - API for file chooser over preset directory
Summary: API for file chooser over preset directory
Status: RESOLVED DUPLICATE of bug 47737
Alias: None
Product: platform
Classification: Unclassified
Component: -- Other -- (show other bugs)
Version: 5.x
Hardware: All All
: P2 blocker (vote)
Assignee: issues@platform
URL:
Keywords: API
Depends on:
Blocks:
 
Reported: 2006-08-10 23:28 UTC by _ tboudreau
Modified: 2008-12-22 13:43 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2006-08-10 23:28:51 UTC
There are file choosers throughout NetBeans, and everyone needs to find a way to
save the last used directory;  if they don't, they have a usability problem.

This seems like an obvious place the platform can help - there should be an API,
e.g.
Utilities.getFileChooser (String token)
which will return a JFileChooser, and if closed with OK_OPTION, automatically
store the current directory, and if a file chooser is requested with the same
token in the future automatically preset the current dir of the filechooser to that.
Comment 1 Marian Petras 2006-08-21 17:06:24 UTC
Reassigned back to 'openide'. I do not think such an API should be made in the
Utilities module, which does not contain any API and there are no plans to
define any API in it. The Utilities module can implement its own caching
mechanism but it will have no impact on the rest of the IDE.
Comment 2 Jesse Glick 2008-11-10 17:30:58 UTC

*** This issue has been marked as a duplicate of 47737 ***