This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 85199 - Add ability to specify colors for individual table cells
Summary: Add ability to specify colors for individual table cells
Status: RESOLVED DUPLICATE of bug 80171
Alias: None
Product: javame
Classification: Unclassified
Component: Visual Designer (show other bugs)
Version: 5.x
Hardware: All All
: P3 blocker with 2 votes (vote)
Assignee: Denis Anisimov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-19 08:33 UTC by dimitris
Modified: 2009-02-19 22:45 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dimitris 2006-09-19 08:33:51 UTC
It would be very useful if individual cells could be displayed with non-default
foreground/background colors.

One possible API for this would be to extende/refactor ColorSchema into a
TableColorSchema so that the getColor() callback also supplies the row/column
coordinates being "queried".
Comment 1 Lukas Hasik 2006-09-19 09:07:19 UTC
feel free to provide that class by yourself. Mobility pack is opensourced. 

http://www.netbeans.org/community/contribute/patches.html
but yu'd have to write the CA http://www.netbeans.org/about/legal/ca.html
Comment 2 David Kaspar 2007-04-10 11:51:04 UTC
Current ColorSchema does not support. To be backward-compatible, it would
require additional TableColorSchema abstract class.
Comment 3 David Kaspar 2007-07-11 10:53:48 UTC
Designer 1 has been removed. Therefore reassigning to Designer 2 module. Probably this issue will be resolved in the future.
Karol, could you check this issue? Thanks.
Comment 4 Petr Dvorak 2008-05-05 16:52:17 UTC
See also issue 80171
Comment 5 Denis Anisimov 2008-12-17 13:31:40 UTC

*** This issue has been marked as a duplicate of 80171 ***