This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 8705 - FolderNode in explorer points to invalid DataFolder after moving folders
Summary: FolderNode in explorer points to invalid DataFolder after moving folders
Alias: None
Product: platform
Classification: Unclassified
Component: Data Systems (show other bugs)
Version: 3.x
Hardware: PC All
: P3 normal (vote)
Assignee: phamernik
Keywords: THREAD
Depends on: 20179
  Show dependency tree
Reported: 2000-12-01 14:39 UTC by pfelenda
Modified: 2008-12-22 18:53 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:

folder structure.... (14.25 KB, application/zip)
2001-10-15 17:22 UTC, Lukas Hasik
Full Tread Dump attached (8.56 KB, text/plain)
2002-01-07 13:51 UTC, pfelenda
full threaddump (13.20 KB, text/plain)
2002-01-07 14:12 UTC, Jan Zajicek

Note You need to log in before you can comment on or make changes to this bug.
Description pfelenda 2000-12-01 14:39:07 UTC
Try cut-paste some files in Explorer ( Filesystems tab, Project tab )
After some cut-paste is not possible paste files -> item paste is disabled.

How to reproduce:
In Filesystems tab :
  1) mount second filesystem
  2) create some files in packages
     (at least 6 packages - it's fast to bug)
      I've created in Filesystems tab:
  3) select all created packages ( pack01, pack11 ....)
      cut -> paste to second mounted filesystem
      (when is all files moved ok then again)

      paste all packages in second
      cut -> paste to first monted disk
     ( do it more then three times and bug appears )
Comment 1 Lukas Hasik 2001-10-11 18:10:04 UTC
dev build 200111100100

I really tried hard to reproduce it....  (more than 5 times cut-paste)

IT works for my IDE :)

reopen if reappears
Comment 2 Lukas Hasik 2001-10-15 17:19:25 UTC
OK, unfortunatelly I have to reopen it :(( Petr showed me that this
problem is still in IDE.

It doesn't matter if you Cut/Paste from/to root of filesystem or
from/to some folder.
When this problem occurs then even Paste after Copy is disabled BUT
only for the same items which you wanted to Cut.
And copy/cut/paste different items but those items which had the
problem can't be copied/cutted anymore - only Unmount and re-Mount
filesystem helps.

Comment 3 Lukas Hasik 2001-10-15 17:22:13 UTC
Created attachment 3019 [details]
folder structure....
Comment 4 pfelenda 2002-01-07 13:47:35 UTC
(Build 200201070331), jdk1.3.1_01 or jdk1.3.1_02

I'm tried this bug reproduce. But todays night build freeze on
my Linux box.

How to reproduce :
 - unpack attachment from Lukas H. to folder xx
 - Mount folder xx as second filesystems to explorer
 - Select all folders in folder xx
 - cut selected folders (ctrl-x)
 - paste to first filesystems (sampledir) (ctrl-v) 
==> IDE freeze

Comment 5 pfelenda 2002-01-07 13:51:46 UTC
Created attachment 3991 [details]
Full Tread Dump attached
Comment 6 David Strupl 2002-01-07 14:00:17 UTC
Seems like a deadlock in loaders. Petr could you please evaluate it?
If it is not in loaders please reassign accordingly.
Comment 7 Jan Zajicek 2002-01-07 14:10:17 UTC
Easy reproducible with attached structure or on sampledir folder ->
increasing prio to P1 - showstopper. Will attach ftd from jdk1.4.0.
Comment 8 Jan Zajicek 2002-01-07 14:12:32 UTC
Created attachment 3992 [details]
full threaddump
Comment 9 Jaroslav Tulach 2002-01-08 14:16:36 UTC
Petr, this is a very interesting deadlock - it would be good to write
a JUnit test that will reproduce it and prevent such problem in
Comment 10 phamernik 2002-01-08 14:52:32 UTC
There are actually two different bugs:
1) the original bug - Paste action is not enabled (reported in NB3.1,
2) deadlock in datasystem

These two bugs are not connected.

The deadlock was caused by bugfix #18110 (integrated 11/30/2001) and
was just fixed in MultiDataObject (revision 

The disabled Paste problem seems to be reproducible to me (release33
branch - Jan 8th).

I'll let the bug open, because the first problem. I am going to change
the priority P1->P3 again.

Comment 11 Jan Zajicek 2002-01-09 12:31:12 UTC
The deadlock doesn't appear in build 200201090940 anymore.
Comment 12 phamernik 2002-01-22 09:49:34 UTC
The problem with disabled Paste is reproducible. I wrote the unit test
for it (org/openide/loaders/DataFolderMoveTest).

The bug is in DataFolder's move operation. Sometimes a node visible in
explorer represents only temporary (not valid) DataFolder used only
for moving. Currently I don't know how to fix this bug.
Comment 13 Jaroslav Tulach 2002-01-28 11:56:03 UTC
To fix it try: In DataFolder.handleMove create instead of doing
newFolder = ... try to create a new DataFolder () with overriden
method createNodeDelegate that will return the
originalFolder.getNodeDelegate ()....
Comment 14 phamernik 2002-02-14 10:14:37 UTC
Adding dependency - the test must be fixed first.
Comment 15 phamernik 2002-02-26 10:32:44 UTC
Fixed in DataFolder in revision 
For more details about the bug fix, see the diff:
Comment 16 pfelenda 2002-10-14 15:12:27 UTC
Verified in dev build 200210140100.
Comment 17 Quality Engineering 2003-07-01 16:25:29 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.