This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 89250 - I18N - browser window does not appear on solaris when generating uml report i if multibyte in the path to the html files
Summary: I18N - browser window does not appear on solaris when generating uml report i...
Status: VERIFIED WONTFIX
Alias: None
Product: uml
Classification: Unclassified
Component: Reporting (show other bugs)
Version: 5.x
Hardware: Sun All
: P2 blocker (vote)
Assignee: Yang Su
URL:
Keywords: I18N, RELNOTE
Depends on:
Blocks:
 
Reported: 2006-11-13 20:32 UTC by Ken Frank
Modified: 2007-02-15 17:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2006-11-13 20:32:46 UTC
coco on solaris

if the path to the uml report files have multibyte, like for example if the
project name has multibyte, the mozilla browser does not appear
(one cannot use it standalone either to browse to the location either if using
the actual file names/paths

but usually if the multibyte is sent to browser as %E5%A6 .... 
notation, then the browser will be able to recognize it and show the pages.

so this issue is for that transformation to happen.
Comment 1 Yang Su 2006-11-17 00:28:14 UTC
*** Issue 89515 has been marked as a duplicate of this issue. ***
Comment 2 Yang Su 2006-11-22 23:26:58 UTC
This is a common issue across NB IDE on solaris platform, the openide library 
HtmlBrowser.URLDisplayer.showURL() takes raw file url and invokes command to
bring up browser. However, the browser on solaris can not take the unescaped url
path, which caused the described issue, it's not UML specific. When generating
javadoc on java project, user will encounter the exact same behavior, the
workaround is to use browser open file menu to open the target file, in web
report case, it's <project_dir>/report/index.html.

Since the root cause lies in browser on Solaris and openide library, we can not
do anything to fix or avoid the issue, I suggest we open another one or
re-categorize  this issue to pass it to NB team.
Comment 3 Ken Frank 2006-11-23 03:18:21 UTC
The file open did work to get to a report index.html that was in a dir
that had multibyte in its name(in this case the project name)

But for a diagram within it, that had multibyte in its name,
clicking on that diagram on left side of the index page,
gave the same error

and in this case the workaround did not suceed.
(each diagram has its own subdir off of the report dir)

Suggest a release note or other information be provided about the workaround and
limitations; in nb other workarounds are done - for web app, the context root
is seeded from project name and when proj name has mbyte, underscores are
substituted; but this might not be helpful for uml reports if in same dir
there could be 2 or more filenames that would be similar except for the mbyte,
but when underscores are substituted the names would be the same and not
allowed for the 2nd one to be created or would overwrite the first one.

ken.frank@sun.com
Comment 4 Yang Su 2006-11-23 07:17:53 UTC
Not displaying page correctly with multi-byte char in package and diagram name
under some encodings is a separate issue, that's why I reopened 89515 to track
since both behavior and root cause are entirely different. See more description
in 89515.
Comment 5 Ken Frank 2007-02-15 17:34:47 UTC
verifying to get off dashboard even though this is a wont fix one.

ken.frank@sun.com