This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 93906 - style editor - background image - should use same files dialog as used by components
Summary: style editor - background image - should use same files dialog as used by com...
Status: RESOLVED DUPLICATE of bug 93904
Alias: None
Product: obsolete
Classification: Unclassified
Component: visualweb (show other bugs)
Version: 5.x
Hardware: All Windows XP
: P3 blocker (vote)
Assignee: Winston Prakash
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-01 23:40 UTC by bugbridge
Modified: 2007-12-07 16:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2007-02-01 23:40:41 UTC
Original submitter: krystyna

Description:
build 1128_3



-drop a component and invoke style editor, then press '...' of background image
>on Windows you get the Windows default file view of My Documents
>on Solaris it defaults to web dir of the project

Enforce consistency and use same dialog as used by image component url property
et al.

Evaluation:
Both style editor and CSS editor uses  the URL editor from the JSFCL module for
selecting the image. This uses AWT based file chooser which is heavily OS
dependent. However, Image component uses different Custom URL property editor
from "propertyeditors" module which uses SWing based file chooser which is
heavily OS independent. 
Unfortunately, this can not be used because it expects a URL property editor.
Since  style editor and CSS editor do not deal with URL property it can not be
used. For mako we should convert the Custom URL property editor in to a utility
for image selection so can be used at other places too.
Comment 1 Winston Prakash 2007-06-23 01:30:18 UTC

*** This issue has been marked as a duplicate of 93904 ***