This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 94751 - Tooltip Naming Inconsistency
Summary: Tooltip Naming Inconsistency
Status: NEW
Alias: None
Product: obsolete
Classification: Unclassified
Component: visualweb (show other bugs)
Version: 5.x
Hardware: PC Windows XP
: P4 blocker (vote)
Assignee: Winston Prakash
Depends on:
Reported: 2007-02-06 20:21 UTC by bugbridge
Modified: 2007-02-06 20:21 UTC (History)
1 user (show)

See Also:
Exception Reporter:


Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2007-02-06 20:21:04 UTC
Original status: 1-Dispatched; Suggested Status: NEW

Original Target Release: shortfin_dev; Suggested Target Milestone : 5.5

Original submitter: joellelam

There is an inconsistency in the tooltip naming of some of the components.
   * Grid Panel=Table that organizes child components into a grid
   * NGroup Panel=Organizes child components in a flow with an optional
separater between them
   * Layout Panel=Organizes its child components using flow or absolute positioning
   1 Modify Grid Panel to say "Organies child components into a grid"
   2 MOdify Group Panel by removing "between them".  This is redundant with
   * Page Separator=A horizontal page separator line
   * Tab Set=A container for a set of Tab components
   * Tab=A single tab specified as part of a TabSet component
   * Page Alert=Layout for a full page alert including title, action buttons and
optional input components
   * Property Sheet=Represents a PropertySheet
   * Property Sheet Section=Represents a PropertySheet section.
   * Property=Represents a Property
   * Form=Represents an input form whose contents may be submitted by the user,
or via a client side script.
  * Decide to use "Represents a SOMETHING" or just "A SOMETHING"

Description (Entry 2):
A few more inconsistencies:
  Advanced Category:
    * Link=An implementation...
    * Meta=This is an implementation...
    * Script=This is an implementation...
    * Markup=This component...
    * Load Bundle=A

Recommendation 1 and 2 are fine in my opinion.

About the next recommendation ( use "Represents a SOMETHING" or just "A
SOMETHING"...) I'd get rid of the represents and try to replace it with more
descriptive text, like e.g. "Panel where a user can view and modify values of

Evaluation (Entry 2):
Dusan, should we sent this back over to the components team to come up with a
more descriptive name?