This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 97210 - uninstaller fails in bundled jdk on RHAS4.0
Summary: uninstaller fails in bundled jdk on RHAS4.0
Alias: None
Product: installer
Classification: Unclassified
Component: JDK bundle (show other bugs)
Version: 5.x
Hardware: PC Linux
: P2 blocker (vote)
Assignee: mslama
Keywords: RELNOTE
Depends on:
Reported: 2007-03-05 16:21 UTC by Jan Lana
Modified: 2007-09-17 14:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:

Output of 'sh -x uninstaller 2>log' (51.89 KB, text/plain)
2007-03-05 16:27 UTC, Jan Lana

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Lana 2007-03-05 16:21:08 UTC
Bundle: jdk-6u1-nb-5_5
Tested build: mlfcs/200612070100_1
Locale: en, pt_BR

Uninstaller fails on RHAS4.0 with the bundled jdk (6u1). It just happen on RH,
Solaris and Windows version works well.

The uninstaller starts and after ~2sec prints 'Verifying JVM.' and finish.

I tried to run the uninstaller with another java version (jdk1.5.0_11) and it
works well.

Step to reproduce:
 - run ./jdk-6u1-nb-5_5-linux-ml.bin
 - export JAVA_HOME=$HOME/jdk1.6.0_01
 - cd netbeans-5.5/_uninstaller
 - run ./uninstaller

See the attached output of 'sh -x ./uninstaller 2>log'
Comment 1 Jan Lana 2007-03-05 16:27:05 UTC
Created attachment 39175 [details]
Output of 'sh -x uninstaller 2>log'
Comment 2 Jan Lana 2007-03-06 09:48:36 UTC
I tried
/home/tester/jdk1.6.0_01/bin/java -jar uninstall.jar
and it works. 

Interesting, because 
./uninstaller -is:javahome /home/tester/jdk1.6.0_01
Comment 3 mslama 2007-03-06 11:45:19 UTC
Problem is that bundle uninstaller ignores -is:javahome command line option.
Uninstaller of standalone NB IDE works fine. It is InstallShield problem. I do
not know if we will be able to patch uninstaller launcher.
Comment 4 mslama 2007-03-06 14:13:00 UTC
It is common issue not only for bundle uninstaller. On Linux/Solaris uinstaller
ignores command line option -is:javahome. Unfortunately we are not able to fix
this issue. Workaround is to run installer directly using 'java -jar
uninstall.jar' if uinstaller launcher fails to locate JDK.
Comment 5 mslama 2007-03-06 14:25:16 UTC
It is more complicated: Uninstaller launcher first tries to search JDK using
predefined rules. If it fails then it can use -is:javahome. Installer launcher
behaves differently. Anyway whole algorithm is complicated and is out of our
hands. It is InstallShield code. So workaround still applies: If uninstaller
launcher fails to locate JDK try -is:javahome. If even -is:javahome fails run
uninstaller directly with 'java -jar uninstall.jar'.

I even tried to set all uninstaller options in installer project for bundle
uninstaller launcher to the same values as for standalone IDE uninstaller
launcher but behavior did not change.
Comment 6 mslama 2007-09-17 14:39:13 UTC
We will have new installer for jdkbundle NB 6.0 + JDK X so this issue will be fixed in 6.0.