Issue 127581

Summary: Writer crashes after copying all content
Product: Writer Reporter: timo.e.peltonen
Component: editingAssignee: AOO issues mailing list <issues>
Status: CLOSED FIXED QA Contact:
Severity: Critical    
Priority: P5 (lowest) CC: jbsteidel, jim, josef.latt, knmc, mseidel, oooforum, pats, pescetti
Version: 4.1.4Flags: jim: 4.1.5_release_blocker+
Target Milestone: 4.1.5   
Hardware: PC   
OS: Windows 10   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
This is the document whose contents cause the problem.
none
short Writer ODT file, text with picture, also crashes on copy none

Description timo.e.peltonen 2017-11-03 16:38:40 UTC
This has worked for years, but not in the new version 4.1.4.:

I copy content from a web page (several short text items) to an OpenOffice document (in .doc format). Then I choose ctrl+A, ctrl+C to copy the content to paste it in my e-mail, but the ctrl+C command crashes Writer. (Same happens if I choose "copy" from the drop-down list.)

It did not help to a) restart the computer or b) to save the file as an .odt document and then try copying.

I should also add that I have not been able to install the newest updates of Windows 10. If I do so, my HP EliteBook 8440p stalls completely.
Comment 1 Patricia Shanahan 2017-11-03 21:29:19 UTC
I was not able to reproduce just following the comments. Could you post a sample .doc that gives you the problem?
Comment 2 timo.e.peltonen 2017-11-09 18:15:00 UTC
Created attachment 86253 [details]
This is the document whose contents cause the problem.

In case you wonder: the contents of the document are TV program listings the likes of which I copy and paste from the Finnish TV stations' website weekly. (The bottom half of the document.) This is part of my job as a freelance journalist.

Even though the document contains no secrets it does include my brief comments on some of the programs. Thus it would be my preference that the document not became public.
Comment 3 Keith N. McKenna 2017-11-09 20:18:42 UTC
I can confirm with the attached document with the following configuration}

For Desk Top Configuration
Intel (R) Pentium(R) CPU 4405U @2.10GHz, 2112MHz, 2(Core(s) 4 Logical Processors
Total Physical Memory 8.00 GB
Operating System: Windows 10 Home Version 10.0.15063 Build 15063

Apache Open Office:
AOO414m5(Build:9788)  -  Rev. 1811857
2017-10-11 20:12
Language: en_US
Additional Language Packs: None

The problem seems to start on page 2 where the format shifts to using tables. Untithere is no problem with copying via ctl-c or edit/copy. Even trying to select just the table cause the copy to crash with the "Due to an unknown error..." dialogue.
Comment 4 Patricia Shanahan 2017-11-10 02:37:04 UTC
Thanks for the example file - it made it much easier to track down.

The bug is a failure in the LinkManager changes to allow for a pointer being NULL. I expect to have a fix tomorrow.
Comment 5 SVN Robot 2017-11-12 00:12:56 UTC
"pats" committed SVN revision 1814994 into trunk:
#127581# Writer crashes after copying all content
Comment 6 jsteidel 2017-11-14 15:56:36 UTC
Created attachment 86261 [details]
short Writer ODT file, text with picture, also crashes on copy

Ctrl-C or right-click copy to copy parts before, including, and after picture causes crash and starts recovery process: 
"OpenOffice 4.1.4  
OpenOffice Document Recovery
Due to an unexpected error, OpenOffice crashed.  All the files ou were working on will now be saved.  The next time. OpenOffice is launched, your files will be recovered automatically. ..."

OpenOffice automatically relaunches and starts recovery.

The problem appears to match 
Apache OpenOffice (AOO) Bugzilla – Issue 127581
but has a picture instead of table
Comment 7 Jim Jagielski 2017-12-07 16:24:46 UTC
Trunk patch backported to AOO415 in revision 1817392

Need to verify fix.
Comment 8 jolatt 2017-12-08 09:02:15 UTC
Verified with Apache_OpenOffice_4.1.5_Linux_x86-64_install-deb_de_2017-12-03_12:47:08_1817032.tar.gz

OS: Ubuntu 17.10
Comment 9 Keith N. McKenna 2017-12-09 02:17:30 UTC
Verified with Apache_OpenOffice_4.1.5_Win_x86_install_en-US_1816477.exe