Issue 71542

Summary: Compatibility with Nuance/Dragon Naturally Speaking
Product: Writer Reporter: katherinekatz <kkatz>
Component: editingAssignee: requirements <requirements>
Status: CLOSED WONT_FIX QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues, jbf.faure, oo, rainerbielefeld_ooo_qa
Version: OOo 2.0.4Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
See Also: https://issues.apache.org/ooo/show_bug.cgi?id=70567
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description katherinekatz 2006-11-14 23:34:50 UTC
Make writer compatible with Dragon Naturally Speaking commands such as “Bold 
that” “underline that” “correct that” (when you are talking about something 3 
paragraphs ago) etc. 
This would increase OOo’s use among the business community. A growing 
proportion of businesses use Dragon to work with. 

I know this is a long term project but it’s a good investment in the future of 
OOo. Speech recognition is the future of the office.
Comment 1 maxqnz 2006-11-15 00:00:51 UTC
I do not believe this an OOo issue. Adding support for OOo should de done from
the Dragon end, not the other way around, imo. Certainly this is how it has been
done previously with applications ranging from WordPerfect to Firefox and
Thunderbird.
Comment 2 michael.ruess 2006-11-15 07:43:01 UTC
Reassigned to ES.
Comment 3 eric.savary 2006-11-15 13:24:19 UTC
Reassigned to Requirements
Comment 4 Rainer Bielefeld 2009-01-26 13:55:07 UTC
*** Issue 92897 has been marked as a duplicate of this issue. ***
Comment 5 Rainer Bielefeld 2009-01-26 13:59:45 UTC
I have been using Naturally Speaking (9.5 Preferred, German Version) for some
days and I can not confirm that there is a general problem to a use "Naturally
Speaking" together with "Ooo 3.0.0 (DE) Multilingual version German UI WIN XP:
[OOO300m9 (Build9358)]". I will contribute my experience more detailed, soon.
Comment 6 tommytiko 2009-01-26 17:05:22 UTC
For me this is an important issue.  The 2 main reasons I use Word are that it 
works more smoothly with Dragon, and it handles images.  How best to distribute 
between Nuance and Open Office the work involved in achieving full 
compatibility must depend on the circumstances, and on what needs to be done to 
achieve full compatibility.  
Comment 7 1984user 2010-02-03 17:05:07 UTC
I agree with tommytiko. If OOo does not contact Nuance to know what can be done to solve the issue, it 
never will be solved.
Comment 8 lohmaier 2010-03-19 01:35:38 UTC
the most honest and realistic resolution of this issue is wontfix.

The vendors of Dragon Naturally Speaking can modify their software, OOo folks 
cannot. Vendors of DNS know how their software works, OOo folks don't.

Don't get me wrong: If there anything lacking in OOo that would make the 
software work, that lacking functionality can be added. But the vendors of DNS 
need to tell what features they would need.

I doubt that OOo lacks any special features in that regard, as OOo also offers a 
high level of accessibility and corresponding "hooks".

Wontfix just because there's no better resolution. If Nuance contacts OOo folks 
with a set of requirements that are needed for DNS to work with OOo, then the 
issue can be reopened/specific ones can be opened.
Comment 9 lohmaier 2010-03-19 01:38:00 UTC
You, the customers of Dragon Naturally Speaking need to confront Nuance and ask 
about compatibility with OOo.

DNS needs to be modified/enhanced, thus it is an invalid/wontfix issue for OOo.

OOo team will help Nuance when there are technical problems and stuff, but OOo 
cannot modify other people's software.

Thanks for your understanding.