Issue 100189

Summary: Calc takes long time to open xls file with html tags
Product: Calc Reporter: arvindjindal <arjindal.oracle>
Component: open-importAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P2 CC: frank, issues, kpalagin
Version: OOo 3.0.1Keywords: crash
Target Milestone: ---   
Hardware: Unknown   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 104190    
Attachments:
Description Flags
xls file with HTML tags
none
xls file without HTML tags none

Description arvindjindal 2009-03-13 18:19:59 UTC
Hi,

I am part of Oracle application implementation team and I am developing some
reports using XML publisher technology. My client is using star office calc to
view excel reports which takes long time if data exceeds 5k records.

Oracle apps generally open the output of the report in excel and if excel is not
installed on your computer then it prompts you for different application.
Generally users save the output in .xls format on their computer and then open
in star office. Problem is saved .xls file contains html tags too and star
office takes long time to import that file. If same file is saved in .xls format
without html tags, it opens fast.
Could you please suggest some way around.

Thanks,
Arvind
Comment 1 arvindjindal 2009-03-13 18:38:58 UTC
Created attachment 60914 [details]
xls file with HTML tags
Comment 2 arvindjindal 2009-03-13 18:39:49 UTC
Created attachment 60915 [details]
xls file without HTML tags
Comment 3 kpalagin 2009-03-16 13:13:24 UTC
Confirming with OO3.0.1 on WinXP - opening File_With_HTML_tags.xls hungs Calc 
with 100% CPU usage.
What is interesting is opening this file inplace using IE does not cause this 
and file opens just fine.

Suggest fixing for 3.2.1.
Comment 4 arvindjindal 2009-03-16 18:07:57 UTC
Hi,
Thanks for your support.
Just want to let you know that this problem is not only on win XP but also on
Sun OS/Mac which is used by the business extensively.

Also could you please confirm if this issue will be resolved in 3.2.1 version
and when it will be available. We will notify the business users accordingly.

Please let me know if you need any other information.

Thanks,
Arvind

Comment 5 arvindjindal 2009-03-24 17:45:25 UTC
Could you please provide me update on this issue.
Thanks,
Arvind
Comment 6 kpalagin 2009-03-24 19:00:58 UTC
not a feature, but defect.

arvindjindal,
it does not work that fast with OO. If you do not see any progress in, say, 
month, consider raising this issue in dev at sc.openoffice mailing list.
Comment 7 Rainer Bielefeld 2010-05-27 04:56:52 UTC
I agree with suspect in comments from paolopoz Wed May 26 12:49:01 that Issue
104190 might have the same roots (or even be a DUP).